Inadequate resolution for batch export of jpgs from scenes

I know that the way to batch export 2d files from multiple scenes is to uncheck the “Enable Scene Transitions” box in the Window/Model-Info dialog box, then choose Export/Animation.

However, under the Options button on the resulting export dialog box, I can never get export dimensions beyond 1920px horizontal. If I use the Export/2D-Graphic option, I can bump the resolution up considerably (I’m looking for 4K) and control aspect ratio etc. But with over 70 scenes in the model I’m trying to export from, this would be extremely tedious.

Any help in how to batch export jpgs from all scenes at higher resolution than HD (1920 x 1080)???



there was an " Export scenes to jpg" plugin, very old but worked fine

What version of SketchUp are you using? What operating system? What graphics card? Please complete your profile.

I use the suforyou extension to export scenes in JPG or PNG. Works well and has some useful options. It’s here on SketchUcation.

With native tools (assuming you are on pro as your title says) export animation (transitions off). Set the export file type at the bottom of the pop up file location window, choose jpg as format and click options. Set resolution to Custom and enter the pixel width you want.

Sorry to have not filled out my profile. It’s done now. Using SU 2020 on Mac OS Catalina.

Hi endlessfix,

My problem isn’t with using the native feature you describe, it’s in how it functions. Using “custom resolution” and “custom aspect ratio” in the jpg options dialog, if I set to say 3000 x 2000 pixels (first screenshot upload here) and click OK, then hit the options button again, SU changes the pixel dimensions (second upload).

Any thoughts here about why this strange behavior?



It looks to me as if it is setting the aspect ratio to match the model window ratio. If you set the height to 2000, I would expect to see a similar change to the width. If it didn’t make that correction, your images would be distorted. If you set the size to 3000 wide for a single image export you get the same sort of thing, too.

If you really want the images to be 3000 x 2000, you should make the drawing window match that aspect ratio first.

If you want higher res, you probably want to go to larger than 3000 pixels wide.

Thanks for completing your profile. That info is helpful.

Hi DaveR,

Thanks for the reply.

Unfortunately, it resets the two pixel dimensions as I’ve shown in my screenshots exactly the same no matter what size I make the model window, so still stuck.


I did try the plugin/extension suggested above. I was able to export at the pixel dimensions I want (4K = 3840 x 2160) BUT, I encountered a different problem that someone might be able to help with.

When I export using the extension, my text-notation size comes out really small. When I use the native File/Export/2D-Graphic using the exact same pixel dimensions (4K), the type looks as designed in SU.

(see uploads)

Any ideas what’s going on here?