Importing STL files


#1

I have installed the STL extension for Sketchup 2015 and it shows as installed. When I try to import an STL file the status bar shows Importing Geometry for a number of seconds then the UI flickers then it displays Importing STL Done but the image does not show when i click in the workspace the status bar changes to Select Objects. Shift to extend select. Drag mouse to select multiple, but still there is nothing in the work area. I have tried a number of different stl files but none display


#2

Did you go through the Import Options dialog, and set a unit or scale ?

(More than likely it has imported extremely small. Do a ZoomExtents after import to confirm.)


#3

Yes I tried it at meters, feet and it made no difference, I tried it at millimetres and it made no difference I set the template to 3D printing I have tried just about every setting and still no image/object apperas


#4

OK, well then the next thing is to either post some STL files (or links to them,) that others can try to import.


#5

The 3D Printing Template makes no difference.
In fact, it adds a lot of unnecessary clutter to the model…


#6

Have you created the files with STL export yourself? If so, make sure that you don’t used the combination “nothing selected in the model” and “only export selected objects”. In this case, there is no geometry in the saves STL file.


#7

A workaround may be to upload your model in 3D Warehouse and use the new Printables feature!


#8

The files are those which I have downloaded via the site where I am purchasing my 3D printer. They are stored on my computer now. I cannot give you a link to the files as they are only available via subscription. So I cannot give you a link. I am not sure it is exactly legal for me to share those files, and in doing so I may be in breech of legal agreements with the publishers of the subscription and the owners of the files.


#9

Well then test importing some STL files from some other source(s). Just to be sure your Importer plugin and SketchUp are working correctly.

Secondly, go ahead and share the name of the company, and the name of these “problem files.” Someone can at least look into their specific STL file format. (It can differ from company to company because some companies vary from the file specification.)


#10

Thank-you for that information. I only tried that step out of desperation and when it didn’t work I went back to Simple Template - Meters (units Meters) or Simple Template - Feet and Inches (units Inches) (there should be an option to use centimeters with the meters option) - still it is not working.


#11

I try to import very large STL files, about 18.1mb, and Sketchup hands forever, then I need force to quit sketchup. When I press “Force to quit” button, in this precise moment, the sketchup window redraws and show the 3D model, but the quit was done and sketchup is closed by the system…

I hope that you can do some work for fix this.

Manuel…


#12

Hello @manuecs

SketchUp can get slow when adding a lot of geometry. Did you try importing with the “Merge geometry” option off? It may help.

The fact that the model appears when forced closed could mean that the importer was finished importing the actual geometry but was in the process of cleaning up when SketchUp was terminated.

You may need to give it even more time.


#13

Hello.

Yes I try several times import with “Merge Geometry off”, but is the same. some times the app hangs for 30 mins for same file, and the result is the same, the window is redraw in the moment that I force quit.


#14

Can you share the file, or a link to it?


#15

30 minutes isn’t very long, I have waited 12 hours for something to import. It works but often it is very slow, it all depends on what it is.


#16

I have earned to hate Sketchup, if it can not import STL files or quit unexpectedly going to ruin hours of work or full my work with hidden and destructive geometry. :frowning: terrible…


#17

I hope you have not waited 3 months for the import now…