Importing .skp file - get old version

Hi, having an issue where I update one small sketchup model and import into another larger sketchup model (assembly). The assembly does not import the new version of the small model, but instead imports the previous, older version. The date/ time on the small file I’m importing is recent and correct. I’ve tried waiting to see if there is some delay involved with updating a file. Any advice?

Do you use File > import or rightclick > Reload?
What changes did you make?

I used File >import. I made significant changes to the smaller model. I tried it again after several hours thinking it had something to do with timing, but it still imports a previous version. Very strange. This happened once before - same thing, different model. I think I got around it by editing the smaller model inside the assembly. I’m wondering if there is another way around it. Doesn’t seem like this should happen.

Thanks, Greg

Be aware of the context while importing. If the smaller part is inside a larger component, open that larger one, first.

I guess it now just creates a definition with #1 added.

Best to use the reload option, or ‘Swap’ it, when you added some attributes (Dynamic Components)

https://help.sketchup.com/en/sketchup/adding-premade-components-and-dynamic-components

Thanks for the tip. Interestingly enough, I just tried dragging the modified file from Explorer into the assembly and it worked!
Still confused on why import doesn’t bring in the updated file, but OK.