Importing Models into Capture Visualization Software

I am having an issue importing a SketchUp model into an outside piece of software and am wondering if someone more knowledgeable than myself can offer some insight.

Here is the background story:

I have built a model in SketchUp that I am happy with and need to import it into a lighting visualization software called Capture (https://www.capture.se/). This software is for theatrical and live event lighting pre-visualization.

I am able to import the model successfully into Capture and all is well. The part I am having a difficult time understanding is how to get my model scaled properly within the visualization software during the import.

In the import process within Capture, there is a parameter in the Import window called “Drawing Unit” that can be changed by the user. It seems that regardless of what system of measure I used in my SketchUp model when I built it, be it meters or feet/inches, unless I set this “Drawing Unit” to 1 meter, my imported model will be of incorrect size and scale.

For example, I created a test model with a 1’ x 1’ cube and a 1m x 1m cube.

If I set the Drawing Unit to either 1m or 3.28084’ during the import everything exists correctly in Capture and is scaled properly.

If I set the Drawing Unit to something like 1’ (because I drew the SketchUp model in feet and inches), in Capture the 1 meter cube will be scaled down to 1’x1’, and the 1’x1’ cube will be scaled to something close to 3.8" x 3.8".

If I set the Drawing Unit to 10’ in the Import window, the 1m x 1m cube will be scaled up to 10’ x 10’ and the 1’ x 1’ cube will become 3’ x 3’.

The documentation provided with Capture does not go into great detail about this topic (at least not that I have discovered so far). The software developer uses SketchUp extensively so I am confident what is happening is happening by design. I just wish to understand what exactly the relationship is between the model that was created, this “Drawing Unit” variable, and the end product that has been imported into Capture.

The developer states in one of their YouTube videos that SketchUp is “scale aware” and if you attempt to import a SketchUp model into Capture this “Drawing Unit” option should be grayed out and not editable. However that video was made several years ago and in their current software version this is no longer the case.

I intend to reach out to Capture directly but thought perhaps someone here could shed some light on what is going on from the SketchUp perspective.

I realize that understanding is not necessarily required to “get it work right”. If I just set the Drawing Unit to 1 meter everything is fine… but I would like to know why that is the case, and not just “what button to push to make it do what I want”.

Thank you for any insight you can offer.

Scale Test - Feet.skp (125.9 KB)

I think capture is always working in meters and if you ever type " or ’ it simply converts that to the decimal version of that - you can see this happen if you try and set the grid size in the project view setting.

I can’t make sense of it beyond using that like a scale factor before you bring it in.