Importing mesh from file ignoring small faces

I’m trying to import a triangle mesh from file (e.g., .3ds, .dae). However, it seems that some of the faces (triangles) are being ignored. If I scale the model by 10x before importing, then the triangles are in tact. Is there a way to force sketchup to load all faces, even small ones?

Also, immediately after I import my cursor is set to “move mode”, so the object is placed wherever my cursor randomly happens to be. Is there a way to import the model exactly into the current coordinate system without mouse interaction?

How small are the faces you are trying to import? SketchUp is a great program but it can struggle a bit if things get extremely small. Specifically, SketchUp will ignore faces with a area smaller than 0.001 inches. Next, can you post the model itself so we can take a look and make sure that there is nothing wrong with it on a more technical level? If you can not post the model, some screenshots would be the next best option.

As for your second question, if I recall correctly, there is a way to import things and place them via a coordinate system. I will see if I can find a write up on how to do it, and if I can’t find one, I will write something up for you as soon as I have a chance.

I looked through some materials and I can not find a way to directly import to coordinates but you can use the move tool to move items to a set of global coordinates by using the square brackets. For example, typing [0,0,0] will move selected items to the global origin point. For more tips on using the move tool, try this link: https://help.sketchup.com/en/article/3000090.

I realize that this is not an ideal solution and I will keep looking to see if I missed something, or if I can find an extension for you.

No. The best option, as you have already noted, is to import using a larger unit than the original. After a successful import you can scale the model back down without losing the small faces.

Anssi

Thanks for the answers. How are the ignored triangles determined? By area? By circumradius? I’d like to know just how much I should scale the model by. (Besides being an extra step, scaling incurs precision loss. So I only want to scale as much as needed).

SketchUp starts having trouble forming faces when one of the edges is shorter than about 1 mm.

Anssi

FWIW, I’m using the 3D printing (millimeters) template. When I load a .3ds
file triangles are being ignored with edge lengths less then 0.04 “3ds
units (i.e., units in the coordinate system of the unitless .3ds file)”.

You can select the units that SketchUp uses to interpret imported files in the Import Options dialog. You don’t have to scale the model up in another application, you can just select a larger import unit (like Centimeters instead of Millimeters).

Anssi

don’t, it is full of bloat that no one needs…

use the simple template for meters and in the model units set 4 decimal places and to show no units…

import everything in meters, model as if in mm i.e. type 1 if you want 1mm etc…

when you export, use mm and SU will relabel all the meters as mm…

no scaling involved…

john