Importing IFC File corrupts graphics

I received a revit model from an architect, and converted it to IFC using Revit. When importing the IFC into SketchUp, at first glance all looks fine. However, when zooming in, or importing other models - the lines and edges become jagged and pixelated. This is while working in SketchUp, not after importing.

This effects the tools as well.

Has anyone else experienced this, or know how to remedy it?

Your problem seems to be related to your graphic card not with ifc file.

The model is located very far from the origin. When you import it, uncheck ‘Preserve drawing origin’

I thought the same - however have not had the issue in any other models. I have also imported using the Revit importer during a trial on Studio, and didn’t have any issues.

Currently running an NVIDIA RTX A500 Graphics card. I have also tried switching to the default Intel card, but the problem persists.

The blue fixtures seen in the previous screen snip - were drawn in SketchUp, has no issues in other instances until being copied into this specific building model.

Another issue I have, is when zooming in and exploding components, the model start dissolving.

This seems to have worked, I have re-imported into SketchUp and all the lines are clean, the zooming issue has disappeared and the models I bring in now retain their crisp lines etc.

Thank You!!!

1 Like