Importing DWG into 2019

Hello, I have upgraded to Sketch Up 2019. When I import a dwg file into Sketch Up 2018, it imports correctly, including all parts. When I import the same dwg into Sketch Up 2019, there are parts missing, and it’s in color. Colors are not so much an issue, as the missing items are. Also, I saved my dwg file down to ACAD 2010. Any ideas why its not importing all items, or are there settings that can be adjusted to insure all parts get imported using Sketch Up 2019? Thanks in advance for any help!

Are the DWG Importer’s Options the same in both versions of SketchUp ?

1 Like

Is the Import Unit set correctly?

Yes, same Options, except for one…Import Materials is an additional option in 2019

It’s set the same for both 2018 and 2019. I left the default setting of Model Units. I tried changing to inches, and items were still missing on the import into 2019

Can you post a DWG file that behaves well in 2018 and badly in 2019?

Do you get better results if you use a bigger import unit like Feet or Meters?

I am also wondering if some of the imported lines have been coloured the same as your window background (that used to happen when exporting from LayOut, you could get black lines on a black background).

Drawing2.dwg (2.7 MB)

This file works in 2018, but not 2019

Loaded it. See other posting

I got the same results, most of the actual model goes missing. I also tried to import to LayOut. Importing as a SketchUp reference gave the same result. Importing to LayOut entities with the Model Space Only option produced successfully a “flattened” version of the file. I haven’t got AutoCad at home so I cannot at the moment try to, for instance, explode all the blocks prior to importing.

@trent, could you take a look at this? Importing to 2018 and 2019 gives exactly the same errors (for instance, a lot of “out of range” coordinates) but the model imports into 2018 quite well whereas in 2019 most of it goes missing.

Hi all, yes we are aware of some conditions where not all the entities are being imported, falling out of range as Anssi has noted. We are investigating the cause and the best way to fix it.

I will let you know if I come up with a solution to this.

Trent

Any solution? Same problem. And I can’t use the 2018 license because it was upgraed.
This is a real big problem.

Do you have a student license?
When did you bought it?

No it’s a full license that has been updated (from 2018 to 2019) with the maintenance contract.

SketchUp 2019 installed correctly? Right click on installer, select Run as administrator?

Then you could still use the 2018 version unless it is a network license.

when I had 2018 and then I installed 2019 it worked. But I had to format and reinstall windows and now I can’t install 2018 because the serial is no longer valid

This highlights why I find this policy of not being able to fall back to previous versions when you’re all paid up and good with the developer to be infuriating.

2 Likes

A format or reinstall would not affect the Macaddress but you probably have changed the username as well and the combination of macaddress (ethernet LAN adapter) with the Username is what tiers the license…

Unfortunately…

Btw. If you have an active Maintenance and Support plan, you could ask to ‘downgrade ‘ the license…

1 Like

in fact I changed my username, and I went from win7 to win 10 … I will try to install 2018 in a win7partition where I still have the same username

Hi, One of my customer got the same trouble !

please see below the 2017 import

and below the 2019 2019 import

On 2019, I try to
-> import dwg into layout the “drawing space” (not sure about the english name) and import it into sketchup. But Layer are merge because of Layout, …
-> import dwg into layout the “working space”, with and withou sketchup entities option, … same result

I have a message like that “some part are too far of the origin, …”

Please help