Importing Cad hatch patterns destination Sketchup

materials
texture
textures
import
material

#1

I am doing Matt Donley’s video course with Sketchup Pro. It comes with a bonus pack of CAD style hatch patterns I downloaded them onto my laptop and they are in the downloads file. Hopefully if not too stupid a question, but how do I get navigate them into my materials folder in layout? (Windows 10). Also am I right in my assumption that these images and similar take very little computer power as they are images and not lines?


#2

I don’t have Matt’s video course. What is the file extension on the hatches? Very likely they are just image files. You can get them into SketchUp several ways. I prefer File>Import, set the image to be used as a texture and apply it to a face in the model.


#3

Thanks again Dave for speedy response. I have tried to do it as you describe but obviously not doing it right. If I click on listed file name it gives option to bring in as a texture and then reads no file found. Also surely there must be a way of inserting the actual images into the material box so they can be found there where you would want them ideally to be and not sitting in the download folder? Also while we are taking about CAD hatches is there anywhere else that you or anyone else knows where one can get a wider range?


#4

You haven’t answered my question about the file type so I can give you much more useful info. You can save the images you import as textures into a library for later use. (Surely Matt’s course goes into that.) There was an old extension called Mass Material Importer but I don’t know if it has been updated for current SketchUp versions.

You might look at the 3D Warehouse and see if there are any hatches there. There are other materials available in the Warehouse. And you can always use Google’s image search option.


#5

Obviously I’m a slow learner but I can’t see any obvious file extension!


#6

Maybe you need to change your computer’s settings to show the file extensions.


#7

Where do I do that?


#8

See this.


#9

Thanks again. Tried it but I have Windows 10. However it set me on the right course and found it through Cortana. File extension is .skm


#10

So you have a folder of SKM files? In SketchUp, go to the Materials window, click on the Details menu button, choose Add collection to favorites, navigate to the folder with the SKM files and open it.


#11

Yes on the way but I am not quite getting there! Done as you say and the files are in the material folder. The thumbnails are visible but when I click in them to open the thumbnail disappears.


#12

Did you select the folder that the SKM files are in or did you open that folder and try to select an SKM?

Which thumbnails? In the navigation folder that opens after clicking on Add collection to favorites? Or in the Materials window?


#13

in the materials window.


#14

I don’t have that collection of files so I can’t look at it to see what’s happening.

What happens if you click on the thumbnail and then try to apply it to a face in your model?


#15

It disappears. But I think I may have found the solution. There seems to be 2 sets of files. I think the hatch pack works fine but the hatch styles does not. Perhaps the style panel is superfluous.Very grateful for your input.


#16

Styles?

The Styles window is for controlling other attributes, not the materials.


#17

The folder is called hatch styles and came with the download separate to the hatch pack. I thought they were 2 different lots but probably not.


#18

Have you looked at the contents of both folders? Do they all have the SKM extension? Do they have the same file names?


#19

Found it Mystery solved. This was the folder that was downloaded as part of style builder and nothing to do with the course. The course ones now open thanks to you. BTW how do I publicly thank someone on the forum? Still finding my way around here to.


#20

Glad you got the mystery solved. I wouldn’t have guessed this had anything to do with Style Builder.

If it’s me you want to thank, you just did it.

You could mark this thread solved though.