Importing Textures problems


#1

Hi everyone

Another beginners question I am sure but I am having real trouble importing textures into Sketchup 2015.

I am following the tips as below

Click File > Import. The Import dialog box is displayed.
Locate the file you want to import
Click the ‘Use As Texture’ check box if you want your image to be used as a texture upon import (this will require you to paint the image on a an existing surface). See the following ‘Importing 2D graphics as textures’ section for additional information.
Click OK to import the file. The image will appear in the drawing area. Your cursor, which will be the paint bucket, will be anchored to one of the image’s corners. The paint bucket cursor only appears when the image is over a surface where it can be painted.
Click on a surface to anchor the point of the image held by the cursor.
Drag your mouse away from the anchor point to increase the size of the image on the face.
Click again to paint your image on the face. The image will repeat, if necessary, to fill the entire face. A thumbnail of the image appears in the Materials browser’s Colors (Microsoft Windows) or In Model (Mac OS X) section to indicate that the image is a texture. Refer to the Paint Bucket tool for additional information on working with textures.

The texture (in this case a stone wall), imports OK and I can attach it and stretch it over the object fine, but I then cannot find any record of it anywhere. The above instructions say that it will be found in ‘Colors’ on Win 7, but there is nothing there (other than the colours that should be) so as a result I have to import it each time I want to use it.

Clearly I am doing something wrong but cannot figure out exactly what?? :neutral_face:

Any ideas would be good

Many thanks

Richard


#2

Two possible answers:

  1. If you want to use it again in the same model, click the little house icon in the Materials window for “In Model”. The material should appear there.

  2. If you want to use it again in a different model, click “Save As” in the Materials window to create a materials file (.skm) and add it to your collection.


#3

Many thanks,

OK, I think I understand (1.) and have found the item where you state in the In House section, thank you for that!

I take it from what you say in (2.) that the .skm files must be saved ‘outside’ of Sketchup in a separate folder/directory and imported each time it is used in anew model, is that correct?

Thanks for the help!

Regards Richard


#4

They are “outside of SketchUp” in the sense that they are saved independent of the current model and can be used in additional models, but there is a standard materials folder that SketchUp will save them in and you can organize them into collections of related materials (which are actually sub-folders of the Materials folder). Your collections are automatically selectable in the Materials Window.


#5

OK Many thanks for that. Is the folder of your own creation as I cannot find my imported materials anywhere obvious - such as the Materials folder?

Regards


#6

Hi Richard,

I gather from your profile you’re using Windows 7
(Thanks for including that in your profile, it really helps us help you! :smile: )

Look to the top menus in SketchUp.

Click … Window > Preferences > Files
IIRC the default location for all files (except Classifications) is your Documents folder.
However, you can create your own set of folders and use the Preferences - Files dialog to point to them.

See…
Application Preferences Dialog Box (Microsoft Windows) — SketchUp Help


#7

One more factoid: current versions of SketchUp do not create the Materials folder until the first time you save one!


#8

Perhaps that’s the case on a Mac.
On a PC, upon installing SU the default location for all files (except Classifications) is the user’s Documents folder.


#9

Many thanks for that information but I do not see these files in the locations specified,does this mean that the files are only made when something goes into them???

Regards Richard


#10

Many thanks - sorry, read this one after my reply to Geo!! Sorry Geo should have read them all first!

Regards to you both
Richard