Import of Colada file fails

Hello,

I use a specialized software for minimizing energy consumption for buildings. The software is called “Energieberater” and made by “Hottgenroth”. It has an included CAD. I can export a colada format and want to import it into Sketchup. I do get the preview, but after clicking “import”, I get an “import failed” message. Is there a solution for me?

I´ve attached the file, I get out of my Energieberater-software.

Hope, you can offer a solution,

thank you in advance,

Till Hermann

Your profile says you have the SketchUp Go plan. Are you using the browser based version of SketchUp or SketchUp for iPad?

As a new user you can’t add attachments. I edited your level in the forum, you should be able to attach your example file now.

Collada is XML, and many applications have support for export, and most of those may do import as well. But, it’s quite possible the data coming from Energieberater has entries in it that confuse SketchUp. Theoretically an importer should ignore anything it doesn’t understand, but maybe their exporter is using a standard entry in an unconventional way.

When we see the file it should be possible to track down which part is the problem.

Hello Dave,

I do have Version 24.0.483
it is the App used on a Macbook Pro M1
it´s not the browser based one.

Please correct the License Type in your forum profile.

Can you share the Collada file?

I updated my profile.

yes! file is attached…
3D-EXPORT.zip (348.6 KB)

I tried and I couldn’t import it. If you open the file with Blender and export the model to stl you can import that file with SketchUp.

I also got import error in both SU 2023 and 2024.

I then opened a copy of the DAE file in my code editor and saw that there were many materials that had phong effects that SketchUp cannot currently support.

So, I manually deleted the <library effects> and <library_materials> elements and the plain geometry imported.

Böfinger Weg - No Materials.skp (123.8 KB)

1 Like

Ohhhh! Superiore!

I will try tomorrow. Uff! Thank you both for even 2 solutions. Wow!

Have a nice one!

Thanky you,

Till

2 Likes

Good morning!

Just tested your methods…

deleting the <library_materials> leaded into this result:
what am I doing wrong?

The other method with Blender cuts off walls and ceilings…

did you get the same result, rtches?

Universal Importer extension

1 Like

Just change the material/or delete it… the faces are there.

When importing you should mark as checked merge coplanar faces (or something similar… I have it in Spanish)

no, I receive this file… maybe ther should be different options between yours and mine



untitled.stl (121.5 KB)