Import is not importing the most recent version of the model


#1

I completed modeling the individual parts of a weldment and created a new file for the weldment model. Into the new file I imported three different .skp models. I noticed that the last piece I imported was modeled incorrectly. I deleted the incorrect part from the weldment file, saved the weldment file, closed it, opened the individual part file, corrected the model of the individual part, saved the individual part file, closed the individual part file, reopened the weldment file, and imported the now corrected individual part. However the individual part still shows to have the original error. I have also tried closing all files, exiting SU, reopening and re importing but I still get the original incorrect file. I suspect there is a caching setting that I have wrong. Any help is appreciated.

Update. I created a new file and imported the same corrected individual part. It is now the corrected version. However I would still like to solve the original problem so as not to have to create a new file every time a part changes.


#2

If you import another model, it will be in the component window. Try to delete the old one there before impoting the corrected version.


#3

That worked. Specifically I opened the Component window using Windows, Components from the menu bar. I couldn’t find a way to delete a component in the component window but I did find an option in the menu of the Component window that was “Purge Unused”. It can be found by clicking on the black arrow that has a menu symbol that is just to the right of the search window that says “3D Warehouse” on it. After clicking on “Purge Unused” I reloaded the corrected model and it was the most recent version. Thank you for your help.