Import dae error

Hi all,

I am creating a dae exporter, for generating dae files to import into sketchup. I do teh triangulation using eacut. However, if my polygons have interior triangles, they get dropped by sketchup.

I am wondering if this is a bug or not?

By interior I mean, a triangle where none of the three edges are aligned with the polygon edge.

Here is an example file

test_import.dae (3.0 KB)

Here is the screenshot, there should be no hole in the middle. There are in fact two triangles in there, in the dae, but they just get ignored by sketchup.

image

Thanks for any help
Patrick

Collada (.dae) is an XML text file format, so it is possible to inspect it manually to see what is going on.

There are two issues I found. First, the Collada file itself contains an error. It says there are only 8 triangles when the data are present for 10. The two extras are the missing ones in the “hole”. Second, you must have had “merge coplanar faces” set in the Collada import options, because there should be a small triangle inside each of the ones shown in your image (at least, according to the Collada file).

When I fix those two issues I get this:

00%20PM

1 Like

Thanks for your help. I will try it.

Why not create an .skp exporter - saving the step of going via another format?

We have an C API SDK to allow you to read/write SKP files. Have a look at https://developer.sketchup.com/en

After signing up to become a developer you’ll get access to the SDK package.

1 Like