Images are hazy

Hi - This is my first post. When I import image (.png), it comes in looking good, like the original. It’s still stuck to the cursor. Then I click on the location to place, then scale it. As soon as I have scaled it and click, the image turns hazy (whitish, cloudy, foggy, as if you have cataracts).

I am using Sketchup Make, version: 17.2.2555 64-bit. Graphics card Renderer: Intel® UHD Graphics 620, GL Version: 4.6.0 - Build 31.0.101.211. In Window > Preferences > OpenGL, Multisample anti-aliasing is set to 0x, Use fast feedback is unchecked, Use maximum texture size is checked. I’ve tried every combination of these, restarting Sketchup each time, but the result is the same.

The image size is 957 x 535, 1.3 MB, 96 dpi 32 bit. Please help!

Please download a skp. Otherwise it’s just guessing what causes the haziness. How far away is the image from the origin? How did you scale the image?

I’ve attached two pictures. The first one shows it nice and clear, just before it is dropped in place from the import. The second one shows the haze that appears right after it is dropped. No scale has been applied.

I’ve also uploaded the image file itself.

Looks like I can only send one file at a time, so I’ll send two more after this one…
An error occurred: Sorry, new users can only put one embedded media item in a post.

Go ahead and drop it into a fresh .skp and you’ll see what I mean.

Here’s the hazy one…
image

hi,

as royce said, please share a sketchup file. not screenshots. could be you have a ground in your style, could be you have something else turned on or off…

Interesting. As I was preparing a new.skp for you, I imported the image and this time it did not produce the haze! So indeed, there must be something in the settings causing this. I uploaded a copy of my real .skp with everything deleted except the image. Please have a look and see if you can find what is causing it.

It says it’s too big to upload, even though it contains only a single image…Sorry, the file you are trying to upload is too big (maximum size is 16 MB).

So here is a link to it on my OneDrive…
2 Items

You have x-ray style turned on, so you are seeing through the terrain photo in that case.

1 Like

I opened your files, the “hazy” image is not hazy, it’s just that you are using the x-ray style, if you click on the x-ray style icon you’ll see the image without transparency.

By the way, the file size is huge cause you have a lot of stuff besides the image, which you have duplicated in different positions and also another huge image.

The size of that image is almost 18km by 10km

Another thing that you should do is work without length snapping active, it can cause inaccuracy on the leghths.

I purged your file its 123mb now.

Oh jeez am I feeling stupid! Thanks so much for taking the time to investigate. I forgot about xray making things hazy/transparent. Is there a way to have everything above the land transparent, but not the land itself?

Where did you find the other stuff, including the big lake image? I deleted every layer except Layer0 and Terrain before I sent you the file. When it asked what to do with geometry, I said delete. I reopened the file I sent you and still can’t find it.

Regarding lake image, it is just a screen shot. Shouldn’t that only be the size of the pixels in it?

How did you purge the file? I don’t see anything about that either.

I’ve never heard of length snapping. I looked through all the preferences but couldn’t find it. How to turn that off?

Any component you use in your file ever, remains attached to the file even if deleted from the model space. If you open the Components Window/Pallet and click on the in-model icon (the house icon) you will see every component you have ever used in that file still available to re-insertion, regardless of if there is an instance present in your model space. The same goes for textures etc. the way to purge those is in the Model Info window, click on statistics and at the bottom “purge unused”. Purging Unused on your .skp file takes it from 550 mb to 2 mb.

Length Snapping is in model info as well, under Units. It is really best kept off as it can introduce small errors int he model which can be hard to recover from. Turn it off and resave your file, best practice is to turn it off on a fresh file then save that as your default template to avoid ever having it turned on.

The big image is in your backup file, the .skb. not in the .skp file you posted.

You have some scenes, the last one called too x-ray view or something like that, it shows all the hidden elements on your file.