I need help folding this pattern

I am using SU Make 2014. I have been trying to fold this model along radial lines. All I get is a mess. Maybe it can’t be done. I would appreciate a bit of help.Cone Pattern.skp (258.9 KB)
Thanks in advance,

It would be easier to draw it in 3D if that’s what you want to end up with. Otherwise draw the fold lines between the inside and outside vertices. Then select the first face and its edges, rotate the required angle, add another face and rotate again.

You need the missing fold lines. Then rotate selected faces about these lines.
See image:

Dave, Thanks, and good idea. Here is where I am coming from–and trying to get. I want a flat model, but I want to see that it fits with other parts when folded to simulate a funnel before I cut material.

What I tried was creating a radial array of guides, then used the fold function of the rotate tool. I am not sure how you are doing what you are doing, but that is what I want. I was going to approximate the shape with 10 sections each folded at 36 degrees.

Your method looks totally different than the example of folding in the help section.

Dan, thanks.

Without repeating my self, in my reply to Dave, I was using the rotate tool, dragging alog a radial guide, and then rotating, but it was warping everything on the image. There is something I am not getting.

To both Dan and Dave,

  1. Is my problem that I was using 10 segments of 21.6 degrees rather than the native vertices?

  2. How did Dave hide the texture?

  3. How did Dave get the protractor to stand up almost instantly? I fight that all the time!

You can draw the cone, with the given proportions fairly easily. Or, do you need to prove your pattern will fold into a cone?


I think it would be easier to draw it 3D and then unfold a copy to flat. Draw the thing to fit and figure out the pattern afterward. You could use the Unwrap and Flatten Faces from the Extension Warehouse.

The angle at which you need to fold the sides won’t be 36 degrees due to the taper of the cone.

No. Well, I don’t know if the 21.6° is correct but you could do this with most any number of sides.

I switched the face style to monochrome. See Face Styles in the View menu.

You can get the protractor to stand up like I did by clicking and holding while you drag along the edge. After the protractor is aligned, release the button and then proceed with rotation in the usual way.


Hi Shep and Thanks.

You hit the nail on the head…Will my pattern work, as in, did I do the math correctly. :slight_smile:

I have a 12 inch diameter cylinder, this funnel has a 20 inch diameter, so it has to be more than a semicircle. The 20 inch diameter is to shorten the depth of the funnel. If this works, then I will have a height of ~ 6 15/16 and about a 4" opening. When I draw it in 3D and then flatten it, it goes to approximately a 24inch diameter.

I am trying to prove or disprove my math…it has been 50 years since geometry. :expressionless:

Hard to believe that I have used SU off and on since it first came out and never figured that out…either the protractor alignment or the face styles… Oh Well, By golly, I am learning today!

1 Like

@DaveR, @Wo3Dan, @Shep

Thank you all. You answered my questions and more.

I still cannot figure out why 10 bends of 36 degrees does not create a circle, but that is geometry, not sketchup. 8 bends and it is overlapping itself. Go Figure.

Also, I created the file I uploaded by selecting the needed geometry for a larger model and pasting it into a new instance of SU. It seemed to work fine, but I could not create a radial array in it with either the protractor or the rotate tool. When I would enter “*10” after the first line or guide, it would say incorrect angle. Not sure what to make of that.

Thanks again to each of you. Now if I knew how to say this thread is solved.

Ernie Nall

You’re right. It is geometry. The angle between edges at the top and bottom is 36°. If the sides of the shape were vertical, the fold angle would be 36°, too. In the case of your “cone”, though, the fold angle is less than 36°. The taller the cone, the nearer to vertical the fold lines and the nearer to 36°. As the cone gets shorter, the angle decreases until it would be 0° if the “cone” has a height of 0. It’s hard to show in a single screen shot so take a look at the model and you can measure it yourself. In this case the fold angle is ~27°.

Cone Pattern.skp (93.9 KB)

Thanks Dave. and you even measured the angle for me. how did you figure out the angle or did you start with a truncated cone? I printed out my pattern and folded the cutout. LOL

What do you bet the angle is 36 * Len of the side (untruncated)* Sin or Cos or Tan of the slope of the side?

Where did I put that Handbook of Chemistry & Physics???

BTW, ever since I copied that geometry, I still cannot do radial arrays with either tool. I have closed and re-opened SU to no avail and it is in any file I open that it will not work. What could I have broken?

I just guessed at the height of the cone so I don’t know if it is accurate for what you drew. As I said, as the height changes, that angle will change, too. It’s easier to draw the final 3D object you’re after and unfold it than it is to figure out the pattern and then fold it up to get the shape.

I’m too lazy to figure out the math. It’s so easy to do it all graphically, afterall.

I’m not sure what you’re doing wrong for the radial array. You must follow the steps, though. Start the rotation, type in the angle, hit Enter and then type*n or xn, Enter, where n is the number of additional copies you need.

Just take this one at face value.

SketchUp was looking for an angle… but you gave it a value for how many copies you wanted.

…and that happened by adding in the asterisk * (multiplier sign) ahead of number 10.

Try entering in the value without the * character, and you should get past your first step here… which of course is to define the angle of rotation. . . After that you get to enter in how many copies you’d like to have.

yeah, I do a LOT of arrays, but after I enter the angle, hit enter, type x10, or *10 or do the entire angle and then /10, it errors with invalid angle

See my reply to Dave I was typing when you posted. It just quit accepting the multiplier or divisor

Are you hitting Enter after typing the angle?

Yessir, I am. angle, return, * 10, return

It has been working all day!

I think I will reboot my computer and see what happens

Maybe that’ll do it.

Are you putting the space in between the * and the number?