I upgraded to SU 21 Pro right after Christmas but I’ve been battling SU for about a week starting with trying to download Twilight and Vray to try. Neither would recognize SU 21 on my system and only allowed me to associate with my older SU17 version.

I tried to delete SU 21 and 17 all together to start fresh but it wouldn’t because there was a corrupt file in the Uninstall program so I had to use third party software… Long story short, and believe me when I say it was a long story to get a new clean downloaded version.

I’ve now got SU 21 Pro back up and running but I have no MATERIAL. When I open a previous drawing, it shows everything IN MODEL like it should but that’s it. No color, no textures, nothing. As far as I can tell, everything else seems to be normal. What gives and how can I get that file back?

I’ve tried using the “Fix” section in the download prompt and it says everything is good but still no MATERIALS

We’ve seen reports of this before and the solution was to correctly install or repair the installation. A correct installation on Windows requires right clicking on the download installer and choosing Run as administrator. Since you have already installed it, you could try repairing the installation. Make sure SketchUp and LayOut are closed. Find the download installer, right click on it, choose Run as administrator and then, when presented with the option, choose Repair.

After that do a cold reboot of your system.