I have a problem with SketchUp. It shows 'burning pixels' on the screen

I have two laptop Nvidia & AMD graphic card but this crash will be appear with my AMD only, when this crash appear the software will stop working and I can do force close only I don’t know what is the problem.

My graphic card is RX6600M and updated AMD driver, Window 10

Please kindly help me to fix this issue

Did you get it from the AMD website or from your laptop maker? Computer manufacturers typically stop updating their drivers about a year from the model release date. Windows automatic update is not to be trusted. Check the AMD site for an update.

You can also try if turning on or off the “Use Fast Feedback” feature in the Window menu>Preferences>OpenGL and restarting SketchUp would help.

Having only your screenshot to look at, an incipient hardware failure cannot be ruled out. Years ago I had a graphics card failure and it started with screen artifacts in SketchUp before proceeding to black screens and crashes.

If you only see it in this one model, model extents might be the problem.

yes, I have tried to update the latest version on the graphic card driver and windows.
Trying to turning on or off the “Use Fast Feedback” feature in the Window menu>Preferences>OpenGL and restarting SketchUp

But it’s still not fixed this issue.

Are you using an external monitor? Are you connecting an external monitor through a laptop dock? Do the artifacts appear on the laptop screen? If using a dock, does it work better if you connect the external monitor directly to your laptop?

No they don’t have external monitor.