A lot of SketchUp crashes the last few days

Hi all!
I’m new to this community, and I’m not sure this is the place to post this problem. But I try :slight_smile:
My SketchUp started crashing on Sunday (2 days ago) for no apperent reason. Like a lot of other crashes I’ve read about on this forum, I’ve also got a AMD Radeon graphics card.
I’ve uninstalled the two Apps causing others problem (some gaming recording software, can’t remember the name).

I’ve sent a lot of bug reports. Is it possible that someone can have a look into them and see what are causing my problems. I must say that even though I’m an engineer, I’m not that good to understand all the tech stuff anymore. So please don’t ask to many difficult questions :slight_smile:

Users of AMD Radeon graphics cards recently got, without warning apparently, an application called Plays.tv which has been found to cause issues with SketchUp. Remove it and you’ll likely find SketchUp quits crashing.

There are a number of threads already existing in this forum with reports of the same problem and removing Plays.tv has been the fix.

Thank you for your reply.
I’ve allready removed Plays.tv.
Any other suggestions?

Did you reinstall Plays.tv? Leave it uninstalled.

Disable Hardware Acceleration in Preferences>OpenGL or remove 64-Bit sketchUp and install 32-bit instead.

AMD Radeon graphics drivers are notorious for poor OpenGL support especially for 64-Bit applications.

Another option that might work is to roll back the driver to a previous version.

Search this forum for radon and you’ll find a large number of threads showing these cards to be problematic.

I did not reinstall Plays.tv.
I will now try to disable hardware acceleration.

Disabling Hardware Acceleration will remove the Radeon card from the mix and make the CPU do the work. If that fixes the problem, try rolling back the driver to an earlier version and if that doesn’t fix it, switch to 32-bit SketchUp.

Or, change the graphics card if that’s an option.

Disabling Hardware Acceleration was not a good option.
Things get to slow.
Do you think that the drivers will be updated to work properly again?

Yes. But isn’t slow better than crashing frequently?

It’s hard to tell. As I said, they’ve done poor support for OpenGL especially for 64-bit. This isn’t a new thing. One would hope they’d make things better but it hasn’t happened yet. If I were in your shoes and it was possible to do, I would abandon the Radeo card and put in an nVidia GeForce card instead. GeForce users rarely report crashes. I can’t remember the last time I had a crash with SketchUp and I use it nearly every day.

OK, thanks for all your feedback.

Good luck with it.

Ha det bra.