I can't seem to disable extensions

This has been bothering me for a while, but sometimes I get stuck in a weird loop where I don’t appear to be able to disable extensions. I am having that right now, so rather than ignore it I thought I’d ask the question.

I disable them and click apply, but the next time SketchUp loads they are back again.
I feel like I’m missing something?

Any sage advice would be appreciated

Which extensions are you trying to disable?

All and any that are enabled still - some are disabled from previous sessions - I’m just unable to identify why it works sometimes, but not others

Hi, Adam!

After two deactivations, respectively restarts of SketchUp, the extensions that were not deactivated remain deactivated. In some cases, it may not match the deactivation settings in SketchUcation.

The Enabled/Disabled state in the Extension Manager should be written to PrivatePreferences.json in AppData/Local/… on PC. Similar location on Mac. If that file isn’t getting updated, look at why that is. Try disabling the extensions and then save the current SketchUp file. That should get the .json file updated.

@mihai.s mentioned the Sketchucation Extension Store tool. You can disable extension with it but I think that info is written in a different place.

Something is going on weird my fredo plugin installations - I’m going to focus my efforts there.

I can disable some plugins, but disabling libfredo causes a bunch of fredo ones to enable again and I’m back to square one.
My SU installatoins and the associated preferences files take a heck of a beating , so I’ve may well of caused a weird issue.

@TIG may have insight about what is going on.

You should never disable LibFredo, in fact if you try and do that with the SketchUcation Managers there’s a warning, not to do it !
Because all Fredo’s extensions rely on some aspects of LibFredo to function properly it can’t be disabled, unless all of Fredo’s tool are also disabled…
Using the SketchUcation Plugins-Manager lets you prevent any extension’s RB file loading when SketchUp next starts - that’s except the su_ RB files which are always copied over from the Shipped extensions folder, and are therefor not ‘block-able’…
If your settings are not getting remembered properly it can be indicative of a faulty installation of SketchUp…
To try and fix that you can close SketchUp, find the installer’s exe file [usually saved in Downloads], select its icon, right-click > context-menu > Run as administrator…
When prompted choose Repair.
After it’s finished, try restarting SketchUp and see if that’s helped - all file and folder preferences should have been corrected.
Running an installer’s exe by double-clicking it is not the same as doing it properly, even if you have admin-powers it has unpredictable results…

Another thing to remember is that the SketchUcation toolset and SCF licensing extensions must be installed and enabled to manage licensed extensions like Fredo’s…

Libfredo is the only active Fredo plugin - disabling it causes every fredo plugins to be enabled on the next boot. Very odd.

I’d already repaired my permissions etc incase something has gone wrong. Normal day job stuff.
I might just blank all of my preferences and go for a fresh install, something isn’t quite right somewhere and I’ll probably spend longer trying to get to the bottom of that than simply blanking it all.

Libfredo is the only active Fredo plugin - disabling it causes every fredo plugins to be enabled on the next boot. Very odd.
I’d already repaired my permissions etc incase something has gone wrong.

I’ve reinstalled just libfredo and curviloft via the Sketchucation store and applied my license…

They all load in correctly.

So I disable curviloft via the SU Ext. Manager.
Close SketchUp.

It shows as disabled.

Disable LibFredo

Close sketchup
Open it again
Curviloft is enabled again (by itself) and is complaining that it needs libfredo 7.6+ (which is still disabled)

Disable Curviloft again
round and round we go.

I’m going to full clean reinstall 2023.1 I think.

Fully wiped every bit of SU2023.1 from my computer

Fresh install as admin

Installled Sketchucation
Latest Libfredo
Latest Curviloft

Applied License.

Same thing as before.

Well at least I’ve narrowed it down to something related to these ones anyway.

Is there any reason to disable LibFredo6. If you disable Curviloft and have none of Fredo’s extensions running, LibFredo6 really hasn’t got anything to do even if it’s enabled.

Mainly just troubleshooting other issues and removing variable really, but as you say, if the extensions that use it aren’t enabled, you’d think it wouldn’t be doing anything.
I’ll probably just uninstall it until I need to use it

1 Like