I can't open my projects

Hello Guys,

I have a problem with my Sketch’Up pro version 2021.

When i start Sketch’up, i can create à new project but if i need to open an already existing project the software load for a while before displaying the message “Sketch’up has produced a bug splat”.

I’ve tried to open this file with another PC and it’s working, a new instal of sketch’Up dont work on my computer.

This problem has appeared one day whitout any reason.

I need to use Sketch’Up to work all days and it’s a real problem.

I’ve tried to contact sketch’Up support but they dont answer

Bonjour, Commentez-vous fait pour contactez sketchup ? Car ma version 2021 est bloquée et je ne trouve pas de page avec un formulaire mail de contact. Cordialement.


Perhaps there is an extension causing the problem with existing models? I suggest opening SketchUp with a blank new model and disabling all extensions. Then exit out of SketchUp completely. Then start SketchUp by opening an existing SKP model file, and see what happens.

So this worked one day and the next day it doesn’t? What changed on your computer? Typically these kind of Bug Splats are caused by a broken graphics driver and it’s not unusual for a Windows update to include bad graphics drivers. Go to the AMD site and download their latest drivers for your GPU and install them. Then do a cold reboot of your computer (power completely off and restart.)

Also, find the downloaded SketchUp installer. Right click on it and choose Run as administrator. Then when the option is presented, choose Repair.