I cant open files once saved in sketchup 2023

Hello, I am having trouble with saved models not opening. I can run Sketchup 2023 no problem. Once I’ve saved the model the thumbnail shows up as a blank white page (same goes for any previously saved models). When I try to open the file it comes up with select an app to open this .skp file the only option available is Sketchup.exe When i click on that it just refreshes the options again.

Its the same for any models I download from my google drive.

The only way I can open a model now is if I open the application and choose from the recent files tab.

Try repairing the installation of SketchUp. Close the program, find the installer which is probably in your Downloads folder, right click on it, choose Run as administrator, and then choose Repair when the option is presented. After it completes reboot your computer.

Thanks for the reply. I have tried that once before and tried again just now to be sure. It still is not working. Do you have any other ideas?

This topic was automatically closed after 186 days. New replies are no longer allowed.