I cannot launch Sketchup Pro 2016

I am not a frequent user of Sketchup. I wanted to launch it after reinstalling it on my new computer. I have obtained from Prosupport my codes, whereas ther is no mor support for this version, and pasted them in the right windows, nothing occurs as I click on “Add Licence”. I have been able to use the soft anyway for one month, but now I cannot launch it again an when I enter my codes, it seems that I try to activate a lobotomized octopus.
Does anybody have an idea of what I can do (but buying a new license…)?
Thank you!

Perhaps other forum members could give specific advice if you posted a screen shot of the dialog that you cannot get beyond (be sure to blur out any personal or license information). Nothing has changed in SketchUp Pro 2016, and Trimble has not de-activated the classic perpetual licenses for that version.

Unfortunately, that’s not entirely true!

Earlier in the year there were problems with the license server files, some had gone missing. Those were reinstated, and for many people it’s possible to add a license again.

But, not for everyone. I’ve heard of cases where in the same office some computers can add a license and others can’t.

I didn’t yet work out what it takes to make sure the license can be added ok. For me, at the moment, my Windows machines are in the state of not being able to add the license. I need to get one that does add it ok, so I can try to figure out what is different.

@RolandF all you can do for the moment is tell pro support that the license doesn’t get added. They may know of a way to get it to work.

Yikes! I hope you folks can resolve it soon for the affected customers.

Thank you very much, Colin, I shall do it at once.

Thank you very much Tdahl, Colin has just informed me as well. I shall write to prosupport at once.

Thank you again, Prosupport said there is no problem with my license, but I still can’t add it. I have run the repare function (installation program) It still resists to the will of working…
Maybe it is corsican, like me!

When I had to activate a classic SerialNumber/Auth.code type of license, I always used the “Advanced…” option that lets me copy and paste the entire text from the license e-mail into its window and parses the codes from there. I don’t know if that would be of help. Also, check that your antivirus/firewall is not blocking SketchUp from accessing the Internet, and that the necessary ports (@colin , which were they?) are open.

Thanks, I’ll check it out.


Well. I have closed the firewall and tried to click on “advanced…”, nothing happens.
It is curious. Prossupport proposes to subscribe a new licence, this is rather frustrating,
Thank you for trying to help me!

The screen where you enter the license details is actually a bit of code that is online. If I go to that location in a browser, it loads ok, but when tried from inside SketchUp it doesn’t load. As it loads in a browser that should mean any needed ports are open.

My best guess at the moment is that the security on our server has changed, and now does not work well with the version of Chromium that is built into SketchUp 2016. I will talk to colleagues about this, to see if I’m onto something.

Thank you very much.

How about the “no Internet connection” glitch that has plagued at least SketchUp 2018 users?

That was caused by older versions of SketchUp testing a Google address that Google stopped supporting, though with 2016 I do have one case where even with the check changed to bing.com, SketchUp says I’m not online. Haven’t figured that out yet.

I have no idea, maybe it is the same problem?

It seems really complicated I hope you can manage it, thank you for what you are doing.

Hi all,
I’m having this exact problem with Pro 2016. I can’t remove the license from the old desktop and can’t add it to the new laptop. The remove and add buttons simply don’t work.

Is there a workaround already? Thanks!

1 Like

Having the same issue. Colin, please let me know if you found any solution.

Hélas rien n’a abouti. J’ai dû passer à la version en ligne, avec paiement chaque année, c’est contrariant. La licence achetée est perdue, ce qui ne me paraît pas conforme au contrat. Mais c’est ainsi.

Alas nothing came to fruition. I had to switch to the online version, with payment every year, it’s annoying. The purchased license is lost, which does not seem to me to be in accordance with the contract. But that’s how it is.