How to show scale on printed Plan view layout

Hi all–I need help getting scale to show on my prints. I have an engineer looking at the drawing but I am not sure what scale it was drawn / printed to.

Please help me get the scale to print onto my doc

Is your document created in LayOut from a Sketchup model? You should be able to select the viewport and see the set scale in the Sketchup Model panel. If you want to add it to the document you can either just type the scale text into a text box or you can use AutoText anchored to the model to show it. Share your LO file so we can see exactly what you are working with and give you more direct help.

HI Dave! I created the doc in Sketchup pro–then imported to Layout so I could add the titleblock. I am really primative when it comes to CAD design. What is an LO file?

A LayOut file.

1 Like

Gremark Egress.layout (799.2 KB)

So a couple of things. There is currently no scale because the Camera in SketchUp is set to Perspective. It needs to be set to Parallel Projection.

You should create a scene in the SketchUp model with the camera set to Parallel Projection and the appropriate Standard View. The top in this case. Then you can choose a scale for the viewport in LayOut. You should not be using Last saved SketchUp view as thescene for a viewport.

Hang tight and I’ll set it up for you so you can see.

You’re a rock star! Thanks

Thanks. One of those old guys like Keith Jagger, maybe. :crazy_face:

OK, So in SketchUp I set the camera to Parallel Projection.
Screenshot - 9_20_2023 , 1_06_04 PM

Then I created a scene called Plan. After updating the LayOut file I chose the Plan scene and selected a scale that would fit on the sheet.

I also rendered the viewport as Vector after making the previous screenshot.

As for adding the scale to the page I placed a label with the leader attached to the model and chose View>Scale from the Label Text options.
Screenshot - 9_20_2023 , 1_03_50 PM

I selected the leader and in Shape Style I made it transparent so it doesn’t show.
Screenshot - 9_20_2023 , 1_04_51 PM

FWIW, I would do all the dimensioning and text in LayOut instead of SketchUp. You’ll have better control over the appearance and size that way.

Here’s the revised file.
Gremark Egress with scale.layout (1.2 MB)

I would suggest that you open this file, right click on the viewport, choose Open with SketchUp and then save the SketchUp file to replace your original. Then in LayOut, go to File>Document Setup>References. Select the SketchUp file and choose Relink from the bottom. Navigate to where you saved the model file, select it and click OK/Open. That’ll set things up so if you need to edit the model, you’ll be editing the one LayOut is looking at.

I am not seeing how to complete this. The only place I see viewport is in the tray?

You have been so very helpful!

By the way, there are several things you ought to in your SketchUp file before you go to LayOut.

It’s evident that you imported a CAD file into SketchUp. The first step after doing that should be to remove the tags from all edges and faces. Here’s the result of untagging the edges and faces in your model.
Screenshot - 9_20_2023 , 1_17_23 PM
Only groups and components should have tags.

You should also get in the habit of using components and groups. There’s a lot of loose geometry in your model.

That ungrouped geometry is very susceptible to being distorted. Also for things like these racking units, a single component could be made for one of them and then duplicated as many times as is needed. It would streamline your modeling and make it possible to automatically show things like how many there are or other bits of useful info.

1 Like

Right click on the viewport on the page. It’ll highlightt with a blue box around it.

1 Like