How to set texture on a cylinder?


When I have a cylinder with a texture which is incorrectly set, how to correct it? For example when I download log from 3D warehouse. I change the scale of the log to be longer which deformed the texture and I need to correct it. Expect that I have changed the proportions of the texture to try to fit her but I got bad results. I want to paint the original image in original scale. But I do not want to import it from image file because this file is already loaded in model.

kupa.skp (180.3 KB)


You have made unique copies of the log component … that’s good.
But then you scaled the copies to make them longer … bad, because scaling distorts the texture.

Edit the component geometry instead of scaling the component.
That is, Push/Pull to change the length.

Logs.skp (267.5 KB)


Your SU version? I use SU8.

If you change the geometry inside component, you cannot make their length different, do you? That’s why I used scaling of component because I wanted to created different length of the logs.


why? when you can just use one component…

turn off hidden geometry, replace the texture with default, then repaint…

scaling doesn’t break it…



Texture name is “Vegetation_Bark_Ponderosa” but how can I found original texture size? Should I reset texture position and do make it to fit? Then pick the texture and fill the sides by this sample?

A bit different question for logs painting:
When I want to change 4 logs crosscut texture, should I explode it and make new texture? Currently I do not know about different way.


I just painted with the texture found in the model materials browser…

if you paint the two ends with a different end grain, you can flip and/or rotate the log copies for the end to appear random…

or don’t paint the end faces , but add the end grain to the components individually…



But this is the same problem. When I change one component like that, it will change all components.

Wait, you mean two different ends on one component? Interesting!


What John is getting at is materials explicitly applied to faces inside a component dominate a material applied to the component as a whole. So you can paint sides within to set their material and then paint the log from outside to affect only the ends.


well, I describe both, equally badly…



It is not clear to me what you do. It looks like you select component and draw on the component.

It would be help if you used Window Outliner to show what you select.

When I tried, this does not work. I need to edit the component, but than it results into all the sides been same.

I tried flipping method:

kupa.skp (485.1 KB)


I do not understand the second part of the sentence


Explicitly painted faces and edges override a parent’s material setting.

Or said another way, a component’s overall material is ignored by primitives having their own material.


Is there some tutorial on this theme on youtube? I need to see and have some voice explanation what is shown. What I miss in the demonstration above is the Outliner to see the context or current scope.


[details=Helpful SketchUp Learning Links …]####


I show BOTH ways of painting components in the one gif…

after I removed the material from the ends of the log component they all show as white ends…

the original gif was to big so I start from there…

you only need to hover a component [ NO SELECTION SHOWS ] to ‘paint’ it’s unpainted ends…

when you see the bounding box, that is the second method of painting inside a component…

because some are turned around they remain showing the ‘component texture’, until I add a second end texture…



Are you sure it works in SU8? For me it does not work.


painting groups and components ‘externally’ was available in v8…

but as your the only person I know here still using v8 you’ll just have to work out what your doing wrong…

why are you using v8?

SketchUcation has a lot of older version using members, so you could join it…



Windows XP forever. Update never ever.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.