How to get rid of black construction lines

I keep downloading collada files into sketchup pro 2017 and sometimes get these models with gazillkons of black construction lines. How does one get rid of them? Thanks.

Those aren’t construction lines. Open the component for editing and select all. Right click on it and choose Soften/Smooth edges. You may need to adjust the slider in the Soften Edges window.

Sometimes the web of edges can be problematic and won’t respond to the normal soften/smooth action.
In these cases you can use Intersect Faces to get the edges to be able to soften, but it can take a long time.
I find Fix it 101 a hand tool for this.
GIF 10-05-2024 11-15-51 AM

1 Like

Thanks but 2017 doesn’t have fixit extension as far as I can tell.

Well, it doesn’t come with it but you can get it from the link Box provided and install it.

DaveR,
Thanks. I downloaded it but it doesn’t appear to be in my extension manager. Is there some trick? Full disclosure-I’m more of a hand drawing architect and this stuff is completely confusing to me. Sorry!

Downloading it doesn’t install it. Go to Preferences>Extensions and install it. Then quit and restart SketchUp.