How to create a custom scale

In layout.I want best fit on page rather than specific scale, is there a way to do this ?

Hi there,

While you can switch LayOut’s page zoom to best fit for the screen, there is no “Best fit to Page” option. For orthographic views, you can set a custom scale in LayOut, though. (Window > SketchUp model > Ortho > Custom). This should at least let you find/define a scale that you want to return to for a given project or paper size.

Hope that helps!


Thanks Mark,
That worked for me


In a way, zoom extents will get you the “best fit” you may need.

  1. Select the SketchUp view port stretch it to how you want it laid out
    on the page.
  2. In either Ortho or Perspective mode, orient the model
    the way you want it in the viewport. You dont have to worry about
    the size. Just get it in the orientation you want.
  3. Now just right click in the active window and select Zoom Extents.
    This should zoom the model contents to fit the viewport.

I hope this helps


Thanks Chris,
That is what I would expect to do, as with other CAD, but I don’t get the “zoom extents” option from a right click. I managed to get what I wanted from Marc suggestion by creating new scale, but zoom extents might be nice.


Make sure the viewport is in a mode where you can orbit. Double clicking on the model will get you into this mode. From there you can right click and zoom extents.

TIP: It is useful to save your view in SketchUp by creating a scene. These scenes can be accessed from within LayOut through the same context menu that has Zoom Extents.


Got that, a very good explanation, thanks very much