How this person is offseting a single line with no face?

Hello, How are you people doing?

I bought this course on UDEMY on organic modeling and I couldn’t understand how the teacher did this offset with a single line. Any suggestions? And what is that plugin checked on?

It’s not a single line. It’s multiple edge segments in the same plane. Offset will work on that sort of thing. To prove it to yourself, draw an arc and use Offset on it.

Can’t seem to work with me. I created the lines along my vase, like he did, added that single line that is supposed to close the offset, selected the whole thing, then deselect this previous line I mentioned, then I tried the offset… it didn’t work =(

Is there an edge segment at the other end, too? I’m just going out to walk the dog but if you share the .skp file so I can see it, I’ll take a look when I get back.

No hurry! sharing the file… I just did lines… I don’t understand this idea of edges segments, apparently it’s different then lines one after another…
test vase organic modeling.skp (329.5 KB)

In SketchUp we have edges. Note Entity Info when they are selected.

Adding an edge segment at the bottom allows Offset to create a closed loop of edges and then a face.


I welded the edges you drew for the outside of the vase profile so they are selectable with a single click.

In the file you shared, there is an image of the vase and a collection of edges tracing one edge of the image. Your problem may be with selecting all of the edges to enable the offset tool - it won’t work with just one selected because it can’t tell what plane to do the offset in. Use a left-to-right selection box to select all the edges, activate the offset tool, and drag away from the selected edges. At the bottom of the trace there is a sharp corner that causes problems for the offset tool, however,

Edit: as usual, @DaveR beat me to the reply :wink:

I did it! Not quite sure how, but I added another line at the base of my vase, sort of did what slbaumgartner said and it worked! Thanks you guys <3

That’s what I asked you about before I went to walk the dog and what I showed in my screenshot and GIF.

Now that I solved this mystery I can go back to procrastinating sketchup organic modeling… just kidding, not…

BTW, does the artisan plugin makes Sketchup slow? I tried 4 iterations with this vase I’m modeling just to see what would happen and now it’s super slow

Anything you do that increases the amount of geometry in your model increases the amount of work your computer has to do and has the potential of slowing things down. Turning off Profiles in the style can help with performance as can working with Face Style set to Monochrome. Leave shadows turned off, too.


That is the style of the visualization on the viewport, the one you have checked is the one with at allows you to see the materials, to the right is monochrome, the one I recommend to use while modeling, to the left is the one that allows you to see only colors, you could click on them to check what are they for, if you press the K key it will activate the X-ray style one of the most useful in my opinion.

No, K is the default shortcut for back edges view style, which is not the same thing as X-ray.

1 Like

Actually, it depends on your settings. I added Y as a shortcut for x-ray for instance.

K is the default shortcut for back edges, not for X-ray. Yes, a user can change this shortcut if desired, but the point remains that back edges and X-ray are not the same thing!


Your right, I’ve been using k for X-ray for a while I forgot the default style assigned to that shortcut was show back edges.