How does Sketchup decide which profile edges to show

I am trying to show only linework for complex furniture 3d furniture and cannot achieve consistent outlines with profiles turned on in styles… can anyone explain exactly how SU determines which outlines it will display in a 3d model…
eg… if I have a sofa,
is only the primary outline shown?,
only the outline of curved surfaces ?
How are groups or components outlines in the primary object show?

I am struggling to find the logic of the process


It’s pretty simple. Profiles are shown when only one face that the edge bounds is visible. Profiles are applied by component or group. In the above it is pretty easy to see how this works. The front jaw of the vise shows profiles around its perimeter and in a couple of spots on the lamb’s tongue above the hand wheel where the adjoining faces are not visible. Profiles are also shown around the dovetails because the front and side are two different components and the faces in the sockets between the pins are not visible.

Below I exploded the two dovetailed components and made a single one. The dovetails are now outlined as non-profile edges because the faces on either side of the dovetail outline are visible.

It’s also worth considering that if Profiles are turned off, softened and hidden edges are not shown even when the adjoining faces is not visible. Notice how the outline of the knob, wheel and some other spots disappear without profiles.

With Profiles turned on but set to 1, they are displayed but look like non-profile edges.


Thanks Dave for that very clear description… was that by your own trial and error or is there some official description somewhere…

Unlike your mastery of the process I was getting results like your 4th image… maybe it it was because the sofa had many hidden edges or it might also be video driver issues … I will re investigate know you have explained whats going on with clarity…

I guess I’ve never seen any “official” explanation of Profiles. I learned this stuff a long time ago as I was playing with styles to set up one for my default templates as well as for image exports.

If your images are like like my 4th one, I would expect that the style you are using has Profiles turned off. The default Hidden Line is set up that way as are the others that are shown as “fast” styles by the addition of the green stopwatch icon.

Personally I prefer the working style to include profiles but with them set to 1 as in the last image in my previous post.

I did miss out another case in which Profiles are displayed. That is when a line drawn on a face doesn’t divide that face. That can be leveraged for display in some cases but it’s really a good trouble shooting tool. The line drawn across the top of the box in the foreground doesn’t go all the way across. The gap isn’t easily seen but if you were to try using something like Push/Pull on one side of the line, it would move the entire face of the box.

With Profiles turned on, you can see that edge shows as a profile. If it divided the larger face, it would show as a thin line.