How do you pan in layout?


#1

I am new to layout and so far I am not thrilled. I can’t find how to pan - there’s no pan hand to move around in the model. This seems to be a really big oversight. How does one move around in the model? Some times I make several copies of the model in the same file, so I can make variations. But trying to move between them in layout seems impossible.
G


#2

I’m not entirely clear as to what you’re asking. Are you just trying to move the view on the page? If so, you can use the scroll bars on the sides of the window or you can pan just like you do in SketchUp by holding Shift while holding down the center mouse wheel.


#3

Create a Scene in SketchUp for each model view you want in LayOut.

Scenes Manager — SketchUp Help


Scenes


#4

I think one of the Sages needs to explain to you how Layout works. Not having a “Pan Hand” is not an oversight. That is not the way Layout works.


#5

I found the pan hand in the right click camera functions. Strange place for it.

I read that if I made changes in my SU model, they would magically appear in LO - not! LO locks the SU model and it won’t save any changes. So I have to delete the model from LO, make the changes, then re-insert the model. There’s got to be a better way.

I am not a fan of using the diagonal handle to rescale the model - it goes out of proportion if I slightly vary in my mouse handling.

I wish there was a tape measure tool so I can figure out how large it is all coming out.

How do I make the models to scale in the LO drawing? They aren’t much use to build from if they are some random scale.

G


#6

I am going through some of the videos - and some of my questions are being answered. I think one mistake was not launching LO from SU.

I guess I wish the videos were arranged on Trimble’s web site in a more logical fashion - watching them in a random order seems counter productive.

if I understand what’s being told me, I can import most anything into LO but it won’t be to scale. Therefore, I have to load the model or scenes and then LO can scale them properly. That makes sense

Oh well. G


#7

It sounds like you are opening the viewport in LO to reposition the camera and zoom, pan, etc. You can do that and use the mouse for navigating as you should be in SketchUp (scroll wheel, center mouse button, Shift key) but…

As George pointed out, you should be making scenes in SketchUp and using them for the viewports in LayOut. Don’t open the viewports in LayOut to zoom, pan, etc. Make those changes in SketchUp as needed and save the changes to the scenes. Save the SketchUp file and update the reference in LayOut.

When you open the viewport in LayOut to make camera changes, you unlink the viewport from the scene in SketchUp. That’s why it doesn’t update. Even if you inadvertently unlink the viewport (it’ll show as modified in the SketchUp inspector Scenes list) you don’t have to delete from LO and re-insert it.Just pick the original scene from the list.

If you set the camera to Parallel Projection for your scene in SketchUp, you can select the scale in LO for that viewport. No need for random scales.

It does sound like you need someone to show you how to use LayOut correctly. You are just getting frustrated by doing things the wrong way.


#8

You are getting close. First, you don’t have to launch LO within SU. You can open separately. In SU you set up the various scenes you want to display in LO - let’s say a house floor plan. Call it Scene 1. Save SU then go into LO file menu. Scroll down to insert and navigate to the SU model. Insert the model. When the model is in LO, it will show up in the “Sketchup Model” tray and will open a viewport on the LO page displaying the “last scene saved.” In the LO tray there will be a list of scenes. Click on Scene 1 and in a few seconds it will show up in the viewport. Now you can set the scale and move the edges of the viewport to show the entire scene. If you go back into SU and edit the model, you need to update the scene then save SU. Go back to LO and in the file menu, document setup you will see that the reference model is “outdated” .From here you can update the reference model and the changes will show up in the scene in the viewport. Hope this quick description helps.


#9

That’s an easy way to get from SketchUp to LayOut but opening LO and inserting the SketchUp file into it is not a mistake. Either way works fine. You can open the SU file from the LO by right clicking on the viewport and selecting Open with SketchUp.


#10

Two ways: View menu>Pan, or, press the middle button (wheel) of your mouse.

Again, two ways: Right-click on a model view and select “Update model reference” from the contextual menu, or go to File menu>Document setup>References, select the file from the list and click on the “Update” button

The view must use parallel projection (perspectives cannot be to scale): Then you can select a scale from the list in the SketchUp model tray.

Anssi


#11

Ok - I guess I’ll learn how to do scenes. With my earlier versions of SU all I ever did was orient the model - export a 2d graphic which was sufficient for my needs. But now, I am trying to do real plans, and those methods won’t work.

I had thought that LO was more flexible, that I could import a model and copy and manipulate it in the different viewports, to get the orientation / size I wanted. Thus my desire for a pan hand to move the model around inside the viewport.

I still think it’s a good idea.

G


#12

I think once you learn how to use it correctly, you’ll find that LayOut is brilliant for creating things like plans and other documentation. And it is plenty flexible.

You need to keep in mind that in LayOut you are looking at paper space views. That is, you are looking at the document you’re creating. the viewports you add are like images. The images are created in SketchUp as scenes.

I make plans for woodworking projects all the time and I find SketchUp and LayOut an unbeatable combination.


#13

I would like to see LayOut incorporate all the functionality of SketchUp as to how the model is displayed, so that you could have a model contain only the model geometry, and all the aspects now controlled via scenes, styles and layers could be managed from inside LayOut-perhaps section planes, too. It is manageable as it is today, but, honestly, rather confusing, as testified by the zillion user posts in these forums with difficulties just in this.

Anssi


#14

Try this (it’s the lazy way of doing things). Within LayOut:

  • Select the model you want to change the view of;
  • Go to the SketchUp Model tray, and select from the *Standard View* that you want;
  • Hit the *Ortho* button;
  • Select the scale that you want your view to be;
  • Stretch the model to fit the view you want and be done with it, or;
  • Draw a closed shape around the area of the model that you want your view to be;
  • Select the model and the shape;
  • Right-click while you're over both of them, and select *Create Clipping Mask*.

I used to lock (from panning) my viewports in AutoCAD because some folks would accidentally pan and screw up the view. And because most folks didn’t know how to turn it off, they’d have to come to me so that I could lecture them on not messing with my viewports. :smiley:


#15

In LayOut, you would place your SketchUp viewports on a layer of their own, and lock that layer.

Anssi


#16

Indeed. You could do the same in AutoCAD, but it was something people could figure out easily.


#17

Hold centre mouse button down or press keyboard shortcut ‘H’ to pan, press ‘space’ to go back to select tool.


#19

Hey no worries man. I shared this because it’s not even well documented in layout help docs. Not very consistent moving from sketchup to layout. You can go to preferences and change the shortcut too to match. Ps why did they hide your reply


#20

Panning can be done the same way in LayOut as in SketchUp. Press and hold the Center Mouse wheel while holding Shift. Or just press the Center Mouse Wheel and Pan. Shift is optional in LayOut.

If you’re using keyboard shortcuts to access the navigation tools in SketchUp or LayOut, you’re working too hard.