How do I quickly edit the size of a 3-D Warehouse item?

3dwarehouse

#1

How do I quickly and easily edit the size/dimensions of an entity I downloaded from the 3D warehouse?

(e.g. A front door downloaded from the warehouse is 32" wide but my opening calls for a 36" door)
(e.g. A 3-D Warehouse fancy bathroom vanity is 63" wide but my floor plans limit the max width to 48")
(e.g. A fridge I downloaded is smaller than the fridge I plan to buy)


#2

Hi @adasco,

Using the Tape Measure Tool, click on the edges of the object you wish to resize to get its size, then simply type the desired size and press enter to scale the model accordingly.

Using the Scale Tool also works, although you will have to do the math yourself since scaling work with a factor in percentage instead of real measurements.


#3

you can scale to a guide as well…

john


#4

If you get unwanted distortion with the scale tool, you can edit the group/component and use the move tool with a appropriate selection…


#5

Just a bit of a correction there @denisroy you can use specific dimensions with the scale tool. Like many tools in SU it defaults to one thing but can be made to do another.
As you can see here, by adding the m it recognises my input as a length rather than a scale.


#6

Hum, doesn’t seem to work for inches (")…


#7

Really, even ridiculously drunk with the base units set in centimeters I can scale in three dimensions to specific imperial measurements.

Make sure you type correctly and hit enter to finish.

1’4",2’9",3’5" enter

make note of the commas between the three dimensions and the final** enter** to execute.


#8

Curiouser and curiouser, stone sober, base units set to inches, as soon as I hit the shift key I get the red, green, blue scale readings, then pressing " leaves " in the measurement box.


#9

@box, I don’t know if it’s for the same reason as @rboppy but although it works A1 in meters and centimeters, I just tried it in Inches and it doesn’t work here, like if the VCB won’t let me type the inch character (") character.

With both a US layout keyboard and a french canadian layout, I have to use SHIFT which seems to toggle uniform scaling in the scale tool, letting go of the shift just resets the scale, making it seemingly impossible for me to type " in the VCB…


#10

Well, it looks like it could be because you are both foreign, or it could be Win10 which you both have in your profiles.
Could be keyboards or settings or OS, but generally it should work. If it isn’t working that way then it needs to be looked at, even though you are foreigners.


#11

To be honest I’m not sure what you mean with this. Could you pop a screenshot to clarify.


#12

This happens if I type a value before clicking. The status text changes by dropping the prefix to “Scale” and the whole object scales when I press shift. But if I click first, I can type a value and it works.


#13

@box look at my screencapture, when I push SHIFT you see “Red, Green, Blue” appear beside the VCB since I’m scaling in all directions and toggling uniform with SHIFT


#14

Thank you everyone.
Denis and Cotty, your input proved to be just what I was looking for. Kudos and thanks.


#15

which version of SU? i.e. en-US, etc…


#16

My SUp version is 16.0.19912 64 bit, and since I’m in the US I assume it’s US version.


#17

@Box: What keyboard layout are you using down there? DVORAK? :wink:

@john_drivenupthewall: Confirmed behavior on en-US 64bits 2016 versions of Pro and Make on both Win10 and Win7.

@slbaumgartner: Building on your exemple, I got it to work by doing the following:

  • Selecting the scale tool
  • Clicking on a scaling handle
  • Typing 1 (or anything) and hitting enter
  • Then typing my three values and hitting enter

So much like the tape measure tool workflow where you have to actually use the tool completely before being able to enter dimension for it to scale:

What I was trying to do in my previous screencapture was to input my measurements while still in the scale command. That is after clicking on a scaling handle and before typing something and hitting enter.

Looking back at @Box’s first exemple, I see this is probably what he was doing. I was just assuming he was still within the scale command while keying in his values.


#18

Yeah, works here too, with my DVORAK keyboard.:grinning:


#19

No, I click and release to grab the handle, move, click and release to drop the handle and type.
Or click and drag then type, either works. I don’t have to enter anything before typing what I want.


#20

This works. Typing anything and hitting enter is actually to achieve the same goal as click and release to drop the handle.

This is the workflow that doesn’t work for me. Works with meters and centimeters but not for feet and inch (feet symbol (’) can be inputed but I cannot input the inch symbol (")

Very weird.

Do you have to use SHIFT modifier to input the inch symbol at all on your kb layout?