How do I importing an Autocad drawing of a survey

I am having trouble viewing all layers of an Auto Cad Survey import .I have all the layers ticked

You need to give a bit more information.
If visibility of all layers is enabled, you should see the impoerted survey.
But was it imported in an empty existing model? And at what size (unit settings)?
And with ‘Preserve Origin’ disabled? Does the existing modeling space have an active section plane?

Hi Dan
All layers are enabled
survey does import but only layer 0 and if I turn un tick the lot goes blank
I imported it to an empty model set in Architectural mm
don’t think about preserve Origin
I will import it to my model but first Iam trying to do a test in a empty model.
My model has active section planes but not in section plan mode

Are you allowed to share the model? If so, please do.

Iam happy to share the model and the survey ,Though I have never done it before ,don’t know were to start but will try

Should I share to 3 D Warehouse
and should I purge as requested

Use the icon “Upload” when posting here, to include your skp file.

concept 5 rendered with dimensions.skp (1.9 MB)

4309-16DET.dwg (807.1 KB)

If you import the dwg and before importing in options (import window) change to meters instead of mm, you’ll see the imported dwg at, what I presume, the correct size.
If you let the import be at mm, it imports the dwg, but it will be very small and located near the origin.

The dwg imports with way over 50 layers. I can’t see anything wrong with the imported dwg.

@angus : See my post in another thread about DWG import, for “purty” pictures of the dialogs, and the Import DWG Options sub-dialog (along with links to the User Guide):

Yes meters has opened it and now I can dimension from the survey.Thanks
Still cannot view all layers ie text , they are all enabled with a tick

SketchUp doesn’t import text entities from DXF/DWG files. See Specifically, “Understanding what CAD elements SketchUp Pro can import.”

That’s a shame that you cant import DXF/DWG entities. I have a PDF so will get the info from the PDF
Thanks to all for your help .