How could I export to .dxf so dimensions do not change in Sketchup?


#1

Hello there,
I have designed something in Sketchup. I had to then convert it to .dxf for laser cutting. however when the parts came back, they were increased in dimensions. for instance, a feature of size 20.40 mm was changed to 23 mm. or a feature of 25.4 mm was modified to 33 mm.
I downloaded (free version) of Layout Editor and tried to rescale the .dxf file but it does not seem to be promising.
as a result I am wondering if i can go back to Sketchup and fix the problem there, so that dimensions stay fixed when exported from .skb to .dxf? any help is much appreciated.
Karim.


#2

ADD: The 2D DXF exporter from SketchUp does have scale control. Access from the “Options” button (lower right corner) of the file “Save As” dialog.

See help article: http://help.sketchup.com/en/article/114292

* also see bottom half of next post …


Just for general info.

The 3D export options for the following filetypes, have scale controls:

  • 3DS
  • FBX
  • OBJ
  • XSI

#3

Those two lengths scalings are not uniform.

First check dimensions in the SKP model to be sure they are correct.

Then open the exported DXF in a free CAD app like Dassault Systems DraftSight, and check the dimensions again.


Oh here is a big part that must be done before export.

Change the view to a straight on view, like “Top” or “Front”, and then switch the camera to Parallel Projection, ie:
Camera > Parallel Projection (make sure it is checked, and you can only see 2 of the 3 axis.)

Now when you export you’ll see that the 1:1 box is check in the Export Options dialog.

@Tommy The step #1 on the article http://help.sketchup.com/en/article/114292 should have a sub-step that notes the above for full scale exports.


#4

You got it! I made the change to the article at http://help.sketchup.com/en/article/114292 and you should see the changes live in the next 5-10 minutes.

Cheers!


#5

Probably, as Dan hinted, you were exporting a 2D image with a camera that was using Perspective projection - perspective images cannot be to scale. Use Parallel projection.

When you have drawn a flat cutting path in SketchUp, you will still get the best results if you export it as a 3D model. For instance, circles and arcs will export as true geometrical objects instead of being split into straight segments as the 2D export does, and the export will be to full scale automatically.

Anssi


#6

Thanks Tommy, but you left out the word “see” (between “should” and “only”.)


#7

Doh! Sorry about that.