How can I see if a surface is in level? Or what else could be wrong?

I have made a surface in SU and grouped it. now open the group and add lines to the surface in order to split it up in different areas. but it does only work if I add circles on the surface. when I use arc tool it does not split up the yellow area. I suspect it is not on level? maybe?

circles to the left could be as one by deleting crossing arcs - but when i try to delete crossing arc to the arc made to the wright this does not work.

i wonder if i by mistake has managed to end up in different levels (blue axes) however very tiny as it is not visible when orbit - if this is the case can i fix it? it is a simple model and i can start all over but so frustrating that i don’t know what i do wrong…

You could open the group for editing and use the Text tool to place coordinates at vertices around the edges of the circles. Compare the Z-values. Set Units to mm or inches and display precision high so you can see differences in heights.

You lost me - I do not understand how to do this?! Sorry I am not skilled enough…

As I have double lines - i guess it indicates the lines are on different levels? or?

The images only allow us to guess what’s happening.

Can you upload your model - the .skp file?

Just drag and drop it into your next post.

Sorry. I was talking about use the Text (not 3D Text) tool to place coordinates. Here I’ve made an example. You can see how the Z-values on the right hand circle aren’t all 0.0000 indicated that circle isn’t on the same plane as the other one.

Askåker.skp (9.2 MB)

Ah - OK - yes now I see - it is on different levels! Da$£! is there a “simple way” to fix this?!

It would be possible, although tedious, to repair manually. I used an extension to project the edges onto a new face and intersected them to create this:


Does it look like what you really want?

Askåker.skp (9.2 MB)

It does! and even more important it should now then be possible for me to go on and split it up in more areas on the same 2d surface which is needed… have you fixed it in the file you attached?

Yes. The new version is in the model along with yours although I exploded your group and forgot to regroup it.

Thank you so much! but i still have problem :frowning: most likely something simple I do not understand… i try to make arcs to split up the area in sections with the arc tool but it doesnt work… I want to go from one of the circles in a bow to the edge and make curved areas… it seems to work if i use circle but why wont arc tool work?!?

I’m not sure what’s different. You do need to make sure both ends of the arc are anchored on the face as well as the rest of the arc. Might be easier if you start with a face that is larger than the finished dimensions of the planting area. And of course you need to be opening the group for editing before you draw the arcs.

If i start/end the arc on a circle or edge line it should be anchored? When shaping it - i do notice “on surface” before I click - but then not all of the arc is visible?!
Yes i am in the group (or rather never made a group in your version of the file)
not sure how you mean with face lager than the finished dimensions?!
Thank you for your patience in trying to help me!

I hadn’t noticed earlier in your file but I see that you have Length snapping turned on. This could be creating problems for you. Turn off Length Snapping in Window>Model Info>Units and see if it makes it easier to draw those arcs.

And upload your model as it is now.

OK - did not know about length snapper - always learn something new! :slight_smile: doubt it is it but please have a look - i have tried a first arc down in the left corner - can you see not all is visible?!
Askåker.skp (9.2 MB)

after I turned length snapper off… i should have added…

You’re still trying to work on your bad geometry. Maybe I should have deleted it. Try working in the group I made with the corrected geometry.

Oh my misunderstanding! I thought the grouped one - was the old and the ungrouped the new! Stupid - I should have tried the other one… now it works - of course.

Thank you!

1 Like