How can I print what I see?

printing

#1

In sketchup, there is the “Hide Rest of Model” mode. But when I print, Sketchup prints all the model. Is there a way to make it print just what I see? (beyond copy and paste to a new model - awkward, or hiding everything else - if something is already hidden then it will be unhidden when I unhide the model)


#2

Why not just export to pdf and print that. You can set up the page for the size and orientation desired and print the image that is on the screen.


#3

how can i export to PDF? will it just export what I see (when Hide Rest of Model is on)?


#4

You should use layers to control visibility, then set scenes with the relevant layers visible and print that or Export the 2d image…
Using hide is very hit and miss, and you tend to lose things.


#5

Click on File > Export > 2DGraphic. Then under “Save as Type”, select “PDF File” or one of the other available file type choices.


#6

SketchUp Pro only…

Anssi


#7

Got it…I don’t use Make so it didn’t occur to me that the pdf conversion feature is not available in that version. My apologies to all of the Make users following this thread. It may be possible, however, to use a 3rd party pdf conversion software to print out work developed with SU Make. There are various software options available for download or for online application and many are free.


#8

You can always take a screen-shot.
It depends what you want the image for…
e.g. Windows built-in ‘Snipping Tool’ - you just draw a rectangle around what you want the either print it, save as an image file or copy+paste into some other file/app…

Similar tools on a MAC - The ‘preview’ app, or snipping a picture on a Mac using your keyboard is quite simple, you hold the “Command, Shift and 4” together and then select what you want to do a screen shot of. To snip the whole screen you use the Command, Shift and 3" together. It will take a screen shot and copy it on to your desktop.

There are also 3rd-party tools for both OSs to make more sophisticated images and even animations…


#9

simply export it (the view you want) as a 2d graphic, (which is a jpg) and print that. I do it all the time - piece of cake. G


#10

Try doing it when “Hide Rest of Model” is on and you’re inside a nested group and want to print/export just that


#11

The “Hide Rest of Model” setting is an option on View->Component Edit. It was meant as a temporary GUI view modification while editing; the designer didn’t anticipate what you are trying to do.


#12

sigh. print screen is your only option I guess. You know how to do that? I hit print screen, open paint, click paste, which opens the image, crop it, and print it. That should work. G


#13

Or properly setup the model so you can show only what you want to show without resorting to things like opening a nested group for editing with Hide Rest of Model active.


#14

If it’s to much work now to properly reorganize the model you can copy the part you want to show to a separate model just to export the image.

If you already have set up a scene with an exact camera location you want to use you can use Paste in Place for the geometry and use my plugin to copy the camera position.


#15

I’ve got a model of a 48" x 3 3/8" panel with a 14" cutout in the center that I’d like to print and use the printout as a template to cut the cutout. No matter what I do, Sketchup insists on using 6 sheets of paper, when obviously only 2 are necessary. I could print the model scaling to one or 2 pages, but I need the 1" = 1" scale for the template. Is this possible using Sketchup Make?

Later… I chopped up the model to allow it to print on two pages, but Sketchup still wanted to use 6 – pages 1,2,5,6 were blank, but what I wanted was on pages 3&4, so I’m good. But if someone could explain what’s going on here, I’d appreciate it.


#16

See this article at the SketchUp Sage Site


#17

Pretty sure I tried all that, but SU still wants 6 pages for the model, which was totally contained on pp 3 & 4, and should have fit on one – the model fit into a rectangle 7 1/8" x 8 7/16". Printer: HP Laserjet 4050, landscape, 8 1/2" x 11". It looks like SU thinks there’s a lot more empty space than ever existed in the model; Zoom Extents produces what I think it should.Vanity register-1.skp (134.4 KB)
.
Now this is odd. I saved the failing model, then uploaded it, then downloaded it. Another instance of SU opened, and it took only 2 pages to print. If I close my original instance, reopen it, and reload the model, it again takes 6 pages. Clearly I’m missing something.


#18

Vanity register-1.pdf (9.3 KB)


1056 : 816 = 11 : 8.5



#19

Thanks. Unfortunately, the Warehouse Manager is “Currently experiencing technical difficulties with some extension licenses and approvals”, so I’ll have to wait, but I’ll keep trying.


#20

I kept trying, and eventually got it installed, but still saw the same result. BUT then I noticed you had not checked “Use model extents”, so I did the same, and Viola! I remain confused, but no longer have the problem. I did see a Windows popup message from you (?) a few minutes ago, about not needing the extension, but noticed it fly by it as I was switching among screens, and never saw it again. Thanks again, anyway.