Exporting 2d image as viewed on screen


Hey Folks,

Sometime ago (like, a month!) I used to be able to export a 2D image AS SEEN ON SCREEN, and I mean EXACTLY AS SEEN ON SCREEN. So if I selected a group or component, with the rest of the model grayed out, and I exported it, it would be exported exactly like that. Same thing if I selected a component and had the rest of the model hidden, then it would only export the component… well, I can’t do it anymore! Also, no one mentioned it online! Any ideas? Don’t tell me that it was never possible because I’ll hand myself in to a mental institute.

Thank you for your help!

PS: I am using Sketchup 8 pro


you might have to give a little more info on how, exactly, you’re trying to do this because for me, it works**

what Operating System are you using?
what sketchup command/menu items are you using?
what settings within that command are you using?
can you upload an example model which you’re having the problem with?


** for example- i’ve entered one component, the rest of the model greys out then the 2D export shows the same thing… that’s what you’re talking about, right?


Thanks for your reply Jeff

awesome, I am not crazy then. I am not sure why it is not working, I am home now and it works here. I was using a pc, I think windows 8, and I was simply opening the component and clicking on export -> 2d graphic. And it didnt work once! it would just export the whole model, any format, pdf, jpeg, png. I am not sure why really, I’ve tried all kinds of things. I will upload a model from work tomorrow, but I have the feeling that it might be something with the computer at work, because no one there knows that you can do that!


I’m having a reallly similar problem! I was importing some models from autocad 3D, and then exporting them to a different format, the thing is that I had to edit the original autocad file, but now I’m unable to import dwg and I have no idea why, yesterday I had all the options available but today not anymore. Anyone has any idea what’s going on?


Did your SketchUp Pro trial run out? Importing CAD files is a Pro version only feature.

BTW your problem has nothing at all to do with the subject of this thread. You should have started a fresh thread.



I didn’t have the pro version, but I’ve had it for almost a year now and I’ve been working that way for months. Now I’ve download a new trial as a temporary fix.

PS: Sorry for getting in this thread, I just saw that the problem was similar and asked. Thanks for the answer though! :slight_smile:


Here is a model that the trick is not working with! What the balls?

thank you again!

diagram.skp (168.1 KB)


I think it is something to do with my settings because even if I make a new file I get the same thing!