How can I fix the loading of my SketchUp model?

How can I make my model work better? Every time I rotate or move the model all of the textures disappear and have to reload. I already tried purging unused components. I need to have my model working smoothly for a presentation. Any help would be greatly appreciated.

My model:

What you describe is by design. SketchUp doesn’t render textures during orbiting or other navigation when the graphics card isn’t able to maintain a usable frame rate. This happens when you have detailed textures like the brick wall and the books as well as large numbers of them. Some of the textures are excessive in file size, too. This doesn’t help.Unfortunately the graphics card you indicate in your profile is not especially good for what you are trying to do.

If you don’t like seeing the textures dropping out, don’t display them in the first place. Switch to Shaded or better, Monochrome or Hidden Line so your graphics card doesn’t have to work so hard. This will help keep the frame rate up and navigating in the model smoother.

You could edit the larger texture images and reduce their size. That’ll help some but won’t be a total fix. There’s a “Material 5”. The image is around 30 Mb and it has a pixel size of 3648 x 2736. This is much larger than Sketchup will display even with Use Large Texture Size enabled. There’s really no point in have a texture that size.

You say you purged unused components but it doesn’t look like it from the model you shared.

It looks like you could stand to consolidate at least many of the colors in the model. You could also simplify the geometry of many of the components that I’m guessing you got from the 3D Warehouse. The computers, for example don’t need any of the connectors modeled on the backs of the cases and you surely don’t need the computer components inside the cases or the textures applied to them.(You could probably stand to remove the Apple logo as well as the wood grain material from inside the case)

Thank you for your help that has helped me to reduce the file size and get the model running faster. How did you find this “material 5” though? I’ve been trying to find it so I can remove it from my model.

I used Thom Thom’s Material Tools. It will generate a report in the Ruby Console of the materials, their sizes and source paths.

Dave’s advice was excellent, however some further options you may choose to use in order to improve the frame rate of your model is to change the style to another - in my experience the ‘shaded with textures’ preset style tends to work faster than other texture presets. Additionally, turning off edges (seeing as you have shadows and textures to define objects) can greatly improve frame rate as well - this is done in the menu by selecting View > Edge Styles > and deselecting all options.