How can I constrain Orbit to keep my verticals vertical?

orbit

#1

Hi

Orbit is making me feel sea-sick!

Is there any way to orbit only around a vertical axis - i.e. to at least keep the verticals vertical?

Background
After 2 or 3 hours on Sketchup I could have sworn that the vertical lines in a different application were squint. However it now seems that I had been spending too long looking at a Sketchup model with verticals “off to the left” as it were !

Holding down shift put it into pan mode of course I have tried holding down control and/or alt or both, but they seem to have not effect.


#2

Orbit normally keeps vertical up. To override this behavior use Ctrl-Orbit.

-Gully


#3

SketchUp uses the concept of “gravity” during orbit. That is, as Gully says, it tries to keep the vertical axis of your view reasonably stable as you orbit (the vertical on the view might be any direction in the model). If you hold ctrl (alt/option on Mac) SketchUp “suspends” gravity and the model will roll quite dramatically as you orbit. On a few occasions I have had orbit seem to get stuck in gravity-free mode even though I am not pressing the ctrl key, which is very disorienting! Selecting some other tool and then trying again usually restores proper orbit (though it may be necessary to select one of the standard views to restore sanity).


#4

Like @Gully_Foyle and @slbaumgartner mentioned, up is always up, unless you work to make it otherwise… I wonder if you mean that you are having a hard time with the perspective distortion? With Perspective on, vertical lies will tend to “angle” outward, based on your view. Have you tried turning on Parallel Projection under the Camera menu? That might help.


#5

OK I now do seem to have gravity. I think I didnt before. What also helps a LOT is taking the field of view down to a small number.