Hollow frame not hollow


#1

Hi,

I use points to build face and then pull it to draw a hollow frame. For example, a rectangle frame with 4 edges at these points:

[(0,0),(100,0),(100,10),(0,10)],
[(90,10),(100,10),(100,90),(90,90)],
[(100,90),(100,100),(0,100),(0,90)],
[(0,90),(0,10),(10,10),(10,90)],

I want the middle to be hollow. But sometimes the middle is not hollow (please ref the screenshot). What wrong I have made? Is it because the points too close?

Need advice.

Thanks in advance.

Regards,

John


#2

I think this might be because SketchUp is a solids modeling program, so your edges on the face are confusing it.

  1. Clean up your model by deleting the extra geometry
  2. Draw a line over the boundary edge to separate the faces
  3. Delete the faces

If you want your model to be parts, then I’d recommend making each piece into a component.


#3

using group for each edge solved the problem.

Thanks.


#4

Your help is valuable, but this statement is incorrect (perhaps a typo left out the word “not”?). SketchUp is a surface modeling program. Every model is built of planar faces and edges. Inside a closed surface made of faces there is nothing, and two closed surfaces can pass through each other without interacting. A “solid” in SketchUp thus does not have the behaviors most people (and other apps) would associate with that word.

But in addition, unless edges and faces are isolated by putting them in a Component or Group, they are not considered to be separate things. They all stick to each other as one unified collection. Without seeing @wowrs’s code and a sample model I can’t tell you why some of your openings provoked the SketchUp GUI to fill in faces and others did not, but the root cause is that the bits are not isolated from each other.

Using groups (or better, components because your structure has many identical parts) is certainly the solution. But you need a group for each collection of faces and edges that corresponds to a complete object in the model, not a separate group for each individual edge! Perhaps thats what you meant and the wording just wasn’t clear…


#5

Thank you!

I totally agree.

I’m glad I helped. You’re welcome!


#6

How exactly does one group a single edge?


#7

Using the GUI, by drawing the edge, selecting it, and then creating a Group from the selection. Using the Ruby API, by adding a Group to some Entities collection and then invoking add_line on the group’s Entities. There is nothing that prohibits a Group from containing just a single Edge, though such a thing is of pretty limited usefulness.


#8

Good question! I just tried it by:

  1. Start with empty model
  2. Draw 1 line
  3. Select the line
  4. Check the context menu --> No Create Group option

Then I did the above using “Select All” instead of click selecting the line - no difference.

I did manage to create a group containing a single line by drawing TWO lines, grouping them, editing the group, deleting one of the lines.

However, I doubt that’s what the OP did. I suspect @wowrs’s use of “edge” isn’t the same as SketchUp’s meaning as a geometrical primitive.


#9

You are right that the group item is missing from the right-click menu (I have no idea why), but try pressing the keyboard shortcut for create group or menu Edit->Make Group instead.


#10

Edit->Make Group indeed made a group of the line!


#11

is it only to make the single edge available in the outliner? If so…why is it not included in the context menu?
The reason I ask is, I created a cube, opened the context menu, used “select only” all the edges, opened the context menu. Selected make group (which was now there) made a group. it appeares in the outliner. then attempted to select the group and it doesn’t select any group the way it normally would. Is that because it was touching the faces when I tried to create the group?

Now I hid the faces…selected all the edges and made a group in the context menu. Attempted to select a group and it only selects a single edge.

Entity info only lists entities…not groups.
Outliner shows groups.
the groups are not selectable outside the outliner.


#12

I can think of two things that may be confusing you. First, since a face can’t exist without its edges in the same context, when you selected only the edges and created a group, new copies of the edges were made within the group’s context and the originals were left in the model’s context as boundaries of the cube’s faces. Second, to select a group in the GUI you have to click on something that is unambiguously part of its contents. But in this example because there are matching edges both in the model and in the group that can be tricky. The GUI seems to prefer selecting the model’s edges rather than the group. But you can select the group in the outliner window. Or you can drag a selection around everything and then use select only groups.


#13

interesting. selecting part of the group while faces are hidden selects an edge. selecting with right to left selection on a single edge selects a group.


#14

[(0,0),(100,0),(100,10),(0,10)] is my one edge.I grouped it, that is 4 points in it.


#15

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.