“Hide rest of model” does not work for me


#1

I’m trying to use “Hide rest of model” menu option for the first time and it has no effect.

In SketchUp Make 17.3.116 (Mac 10.11.6) I select an object then select View > Component Edit > Hide Rest Of Model. There’s now a tick next to that menu option but nothing has happened - I still see everything in the model. I tried selecting parts of the model and different components followed by this menu option but nothing happens.

Tried a simple test in a new model. Made two cubes next to each other. Select one of them, select “Hide Rest Of Model” but I still see both cubes.

Just watched a Youtube video demonstrating this option and it worked as I expect there.

I’m obviously missing something obvious?

Thanks, Ant


#2

It just works differently.

“Component Edit” refers to the edit mode when you have double-clicked a component and entered it. Since it is a part of the model on which you want to focus now, you may want to see the component instance from all sides without being occluded by the rest of the model. “Hide Rest of Model” hides everything outside of the current editing context.

Analogously, “Hide similar components” hides (or not hides) other instances of the same component definition.


#3

Naturally after posting this I made some progress. I hadn’t selected the component properly - had only single clicked on it. I was also hoping this option would be more granular and work on faces, not just whole components.

I had tried to select some of the faces in the model, and also one of the components, to try and align the component without some of the faces obstructing the view. Still not sure how to do that short of using layers.


#4

You can select the faces and then hide them, either via the entity info window or the edit menu. As soon as you have completed your task, unhide them. SketchUp does not keep a record of successive hide actions, so your only alternatives are “last” and “all”. Using layers to hide them is a bad idea unless you are very careful to immediately reassociate them to Layer0 because edges and faces associated with other than Layer0 can cause very confusing behavior.


#5

Oh! Well that was easy. Thanks very much.


#6

Sometimes it helps to hear new things explained a different way.
The SketchUp Team has produced two videos on the topic.

The original by Tyson.


And this recent version by @TheOnlyAaron