Don't want hide rest of model when editing components

How do I make the state of NOT hiding the rest of the model when editing a component? Most of the time I want to see the other elements. I know how to go to Model Info and uncheck the box that hides the rest of the model, but when I do that it goes back to being checked without my doing anything.

Model Info>Components. Untick the Hide boxes.

Maybe you have a keyboard shortcut for it and accidentally hit it? Personally I couldn’t live without a keyboard shortcut for it as I’m constantly toggling it on and off.


I know how to untick the hide box, but how can I make that the default so that it isn’t ticked unless I purposefully go and tick it?

Perhaps you enabled that feature in your default template? It isn’t normally active so you’d have to go into Model Info and tick the box to make it active.

Once you’ve changed the state of the tick box it’ll remain until you do something to change it again.

It resets to being ticked every time I open the file even though the last thing I did was untick it. Will I just need to untick it every time I open the file? I would love for the opposite to be true, where I have to consciously go and tick it if I wanted to hide the rest of the model when I edit the components.

There’s something strange going on. This is in SU2019? Maybe you have a keyboard shortcut set for it as @RTCool suggested or maybe you have an extension that is doing it. The normal behavior for all Model Info settings is that they remain as set until the user changes them