Hide command only ghosts thing out?

When I use the Hide command, Sketchup only fades the component out with a grid hatch, such that it is ghostly. Is there a settings option I am missing such that the objects completely disappear until I choose to unhide all. Or is this the only option. Watching a tutorial on you tube it appears the components should completely hide.
Thank you for any advice…

You have hidden geometry turned on.
Go View Menu and untick Hidden geometry.

Thank you. I knew it would end up being something simple I have missed out.