Hidden lines spawning out of nowhere

The model I’m working on occasionally generates hidden lines for really no reason. I can delete them by pressing Ctrl+Z, but they continue to appear after a while, which is quite annoying.

I took some screenshots:
With hidden lines

The scale of the group used to be much larger approximately 33000 mm instead of 117,92mm. I scaled it down so that it would be small enough but still big enough to 3D print. I ensured that no part of it is thinner than 1 mm. Since I’ve never 3D printed before, I’m not entirely certain if I’m doing it correctly. (I’m unsure if the hidden lines will appear correctly when the group was originally at its original size.)

Is this odd scaling the reason? I can imagine that SketchUp has a grid or lattice to which all the lines are connected. In my model, certain dimensions have 6 decimal places in millimeters, but probably need some more. Other lines also have this, but these surfaces do not change.

Without hidden lines.

Odd maesurements

It could be due to weird scaling. Share the file so we can see what you are working with exactly.

What version of SketchUp are you using? Please complete your forum profile.

Test voor 3D printer.skp (347.9 KB)

This was saved before the lines appeared. However, immediately after saving the file, the hidden lines reappeared once more…

I can erase the hidden lines as well without anything else happening. But still…

It looks to me as if you have some very slight out-of-planarity going on. Very likely caused by having Length Snapping enabled.
Screenshot - 9_18_2023 , 12_57_10 PM
Turn off Length Snapping.

Also. if you are modeling for 3D printing, you could try what I’ve found to be very successful. I model with units set to meters instead of millimeters. I enter dimensions as if millimeters are meters and export the .stl file at meters. This helps to get away from potential errors due to small tolerances. Example: This is the parts for a steam whistle I’ve been printing. As you can see, the central tube is modeled as 125 meters tall. It prints at 125 millimeters tall.

By the way, you have some missing faces inside that need to be sorted out before this will be printable.

Before i saved again: changed units to meters, and tried to scale it back to the original (but i guess didnt manage to put it 100% the same size as before, no idea how to perfectly scale it to the original because the amount of decimals are more than sketchup shows us).

Before save, again fine enough:

(i can only post 1 image / reply.)

After save, again hidden lines:

I guess i really messed up the dimensions…



Any tips to scale it back correctly or other ways to fix those hidden line problem? To make that distance perfectly 3000mm? instead of 3000,000000000000001532324mm (or something).

(sorry for all replies… 1 picture every reply…)

scaled 1000 times up.

Measure the distance between the corners with the Tape Measure tool. Type in the desired distance and press Enter. This will scale the entire object. When it comes down to it, the 0.000000307mm discrepancy is nothing. My guess is you couldn’t afford a device to measure that in reality.