Having issue with Scale tool (Dave Method)

I posted here a while back about a case I was designing for a Google Pixel 4A, and @DaveR kindly showed me a very effective method for fixing the issue I was having.

Well, I made the rest of the case in 1000x scale, but when I go to scale it back down to 0.0001, it won’t let me. I get a popup alert that reads “Invalid Scale.” So I tried manually scaling it, and got it down to 0.12, and then it just stopped.

I cannot figure out why it’s doing this; but my best guess is that I made some curve in it that SketchUp doesn’t like, and so it doesn’t want to scale it down.

Anyone have any idea what I might have done wrong, or what might be happening here? Any help is appreciated.


Here’s the SKP file before I forget:
google_pixel_4a_case_v1.skp (821.1 KB)

If you really want to scale it down, draw a line that is 100 meters long. Then measure it making sure you click on both ends. Type 100mm and hit Enter. Then agree to resize the model and hit Zoom Extents.

That said, are you planning to 3D print these things? After you clean up the stray edges so they can be solid groups or components, why not just leave them large? Export the .stl file using meters as the units and import them into the slicer using millimeters. Here I’ve left the model scaled up. Note the dimensions in meters.

I exported the .stl file and imported it using millimeters as the units.

Too many zeros.

1 Like

Ah, okay. I didn’t think of doing it that way. If it doesn’t work, I’ll export it like it is and scale it in Cura.

Stray edges? Did I miss something? I thought I cleaned all of that stuff up.

Yes, it is intended to be 3D printed, but I’m actually designing it for a friend I know over the Internet, so I won’t actually be printing it. Although I may print it just to make sure it worked.

Heh, it was a sort of challenge, because he posted it on Reddit’s r/3Dprinting, and someone told him it would cost about $400-$1000. I told him I’d design one for him for free, and he could have it 3D printed. I admit I underestimated how long it would take, and I overestimated my 3D modeling skills just a bit…

Anyway, thanks Dave!

There were a few stray edges in them. I used Solid Inspector 2 in the desktop version of SketchUp to find them.

It’s good of you to do it and you probably learned something along the way.

Really? No, I don’t think so. 0.1 is tenths, 0.01 is hundredths, 0.001 is thousandths…dagnabbit. Now I’m ashamed. Publicly ashamed. I should’ve noticed that. Basic high school math.

Well, thanks Box! I’ll see if that helps!

Actually, @DaveR should’ve noticed that too…Shame on you Dave :wink:

Just kidding, you helped a lot. I didn’t think of using Zoom Extents or scaling it in the slicer.

Have a good evening guys.

I did but I find using the Tape Measure tool easier than thinking about scale factors. Just tell SketchUp how bit you want it to be.

Durn it. I’m using the Web version, which doesn’t have Solid Inspector. Ehh, I’ll try using Cura and see if that detects them. Cura’s usually pretty good about stuff like that.

If you do this sort of stuff regularly you might at least consider upgrading to SketchUp Shop. It does have Solid Inspector.

Keep in mind it’s really not scaling in the slicer. By their nature .stl files have no units. If you model something that is supposed to 100mm long in the print, it doesn’t really matter what units you model it in as long as it’s 100 long. You could model it 100 leagues long. If you export with the units set to leagues and import as millimeters, it’ll be the right size. You can’t really model in leagues but you should get the drift.

Ah, okay. Well then if you did notice that, I’m sorry, although you could’ve said something.

I probably should upgrade, but I’m too cheap to pay for that stuff, and I don’t really like subscriptions to online things. Cura usually notices extra edges/faces and that sort of thing, so I’m trying to convince myself that I don’t really need Solid Inspector.

As for scaling in Cura, I wasn’t sure what to call it, so I just called it scaling. And I admit I’m also kind of confused as to how it works.


Anyway… the Dave method does not require scaling back down. You scale-up an instance of a component of your work. Work on that. Your original will still be small and where you had it, but will receive all improvements made in the scaled up version.

1 Like