Hidden Line Model- poor quality jpegs


#1

Hey guys,
I would like to export my project to .jpeg as a simple hidden line model, but no matter what I try, the quality is still poor. In export options, I set the image size to 4000x1848 pixels, so I guess this is not the problem…but the image has “shaky” lines, that appear to be black-grey, not just black. The lines look the same also in the .skp model so maybe I am missing something in the styles (or any other) adjusting? The style I am using now is Default Style- Hidden Line, in the Edit tab, edges are marked and the profiles are set to 1. Has anyone any idea what am doing wrong? Is it actually possible to export a really nice and high quality hidden line model with smooth lines in sketchup? All ideas are very appreciated! thanks!

(it is necessary to zoom the preview, then you will see the lines as they appear in photoshop, or anywhere else on my computer-in sketchup too. the smaller preview looks much better- actually this would be closer to what I want the final .jpeg to look like)


#2

Hello! You could check your OpenGL settings in the Window -> Preferences. Make sure your Anti-Aliasing settings are set to minimum 2x. That way you’ll have smoother lines.
An alternative thing that I’d recommend you to do, would be to send the model to LayOut and export from there with Vector rendering and High Quality output modes turned on.


#3

Definitely check your OpenGL settings, as high as possible.
One question, have you Upgraded to Win10? Some graphic cards that worked with win7 and 8 seem to be locked out with Win10


#4

When I used to export images from SketchUp, I usually exported at about double the final resolution, with antialiasing turned off. Then I use an image editor (for me it is Photoshop) to downsample to the final resolution. This gives me better antialiasing than SketchUp can manage, and nice thin lines.

Today, however, I find it better to export from LayOut. It has Vector or Hybrid rendering for clean lines, and better control over lineweights etc. In SketchUp edges are always 1 pixel wide, and profiles multiples of that, and the higher your output resolution, the thinner the lines.

Anssi


#5

Hey guys, thank you very much for all your ideas and advices, I tried everything you suggested, I guess the quality is slightly better when I use layouts, but the lines still appear “shaky” and not smooth ( in Photoshop and also printed- smaller than A4).

I am wondering- is there anything else I could try? Is it actually possible to have nice smooth thin lines on a .jpeg exported from sketchup? (Or should I look for another software?)

This is how it looks now, exported using layout. Again, it is necessary to zoom the picture to see how it actually looks like, the preview is much better than reality.

Thank you!

edit:

This is how the image looks like in photoshop, those “shaky” lines…the first pic looks much better when it´s uploaded here than in reality (in my ps or on paper)


#6

Hey thanks, yes, I have upgraded to Win10, but so far, I didn´t notice any problems (except for this one)… I use NVIDIA Quadro M2000


#7

What size are you aiming to print the image? 4000 pixels wide would amount to something like 300…350 mm wide at 300DPI. It is a good resolution for a colour image but possibly a black and white or grayscale image might benefit from a higher resolution, although your printer’s capabilities come into play here too.

To me your JPG looks quite good, Things always look jaggy if you zoom in to pixel level.

300 DPI is what LayOut produces when the output quality is set to high. You can get more that that by either making a paper size that is larger than the one you will finally use, or by exporting a hybrid-rendered page to PDF and converting the result to JPG in another application like Acrobat or Photoshop.

You can also try using other file formats than JPG. JPG is primarily designed for photographic images, and it is not too good for “line art” type things. PNG, TIFF or a vector/hybrid format like PDF/EPS come to mind.

Anssi


#8

The size of the printed image is pretty small, the picture is on a half of A4 page and the “shaky” lines are still visible. The finals should be a little bigger, aproximately the A4 size (plus I´ll also need to project it on a wall during the presentation)

I know images look jaggy when you zoom it too much, I just wanted to show you how it actually looks like, because the first image I uploaded looks much better here than in my PC (no idea why)

I took a photo of a printed image so that you can see how it looks like on a paper. It was printed on a regular home printer (Canon MG7550) , but I have tried some pics with nice smooth lines, that I found online and it looked good, so I guess the printer is not an issue here.

thank you!


#9

There are a number of things going on under the hood when you print
1 The graphics reports to SU what resolution it is operating at , From that Su determines the pixle extends of the model, The size of the window you have based on its dpi. Su knows the size of your model and it also has info of the dpi of the printer you are using and can therefor calculate the page size for printing the model. If you look at the print set up for 1:1 scale it will tell you what the page size is. For 1:1 scale it will probably report a large size unless you have a large format printer. If you printing with a standard desk top printer ( 81/2X11) Su will can do a tiled print out which it does not do good. You are then stuck with the fit to page mode if you want to print on 1 page.
I think you should be able to use an antialiasing setting of greater than 2 , possibly closer to eight but , will not make lines very smooth. It looks like you have profiles selected in the render mode you have set and deselecting that may help. Using a straight line style of 1 -2 pixels way help also. Using Layout should help since then you are not stuck with raster printing
Are you allowed to post your model here??
Remember the aliasing may not be noticeable in presentation since view distance will be long.


#10

The shaky lines are visible also on my PC, for example in photoshop or in photo viewer so the printer just prints what I see on a screen…I think there must be something wrong in my settings in sketchup…

Funny thing is, that the .jpeg (the second image from above) that I uploaded here looks much better on this site than in any software in my computer or on a paper- so do not get the wrong idea that the digital image is already pretty good and the problem is just in a printed version.

Thank you for all the advices, I will try everything you suggested

https://www.dropbox.com/s/oe05vmc7zldt23g/M1.skp?dl=0 here is my model


#11

I attach an example LayOut file I made that behaves OK for me (on screen, haven’t printed it on paper), a PDF I exported from it, and a PNG exported from the PDF to a 600 DPI resolution.

The LayOut file is set to Low screen quality and High output quality. The model view is set to use Hybrid rendering.
This is how part of the PDF looks enlarged on my screen:


The shadows will never be quite crisp as they are based on a raster effect.
And here are the files:
dystopia.layout (264.5 KB)dystopia.pdf (298.5 KB)

Anssi


#12

Just down loaded your model and see some but acceptable aliasing from my view point. You are dealing with a sampled data system and all raster based apps will have that problem. That is based on physics and the Nyquist sampling. I have my NVIDIA card set to use application control and it is using 4x. I could set to 8 or even 16 but improvement is minor. If you want to eliminate in total than use a vector based format and EPS printer but that is expensive.
Have you tried changing the setting in the NVIDIA control panel?


#13

In content, EPS and PDF are identical, the difference is that PDF uses compression. Both are hybrid raster/vector formats using embedded PostScript code. The vector lines in my example PDF file from LayOut can be zoomed in infinitely (of course, they have a real-world thickness).
You don’t need a PostScript printer to print vector files. If a printer doesn’t understand PostScript, the software (Adobe Reader, for instance) you use will rasterize the printout instead of the printer. True vector printers vanished when the world got (I hope, finally) rid of pen plotters some 20 years ago.

(Edit: in my earlier post, I had forgotten to turn the Jpeg compression quality to high in my LO export, resulting in ugly artifacts in the shadows)
dystopia2.pdf (629.1 KB)

Anssi