Export Image Appearance

Hi. I’m creating visuals from my sketchup model and have created a view that I want to export. I think I have changed something in the model setting accidentally because when I export, all surfaces that are opaque become transparent and areas such as glass become opaque.
With previous models this normally exports fine so I think it is something I have changed in the model. I have tried to uninstall and reinstall sketchup as well.

Also the images that come out with all the extra lines are around 150,000KB but the accurate image should be around 150KB

Incorrect Exported Image

It will only let me upload one image but it should have a lot less lines everywhere. Its showing the lines of the object behind the opaque surface.

Thank you for your help!

This is how the image should appear

hello, you must have set the view style as wireframe. go to view > face style and pick hidden line instead

you can also set it here : (red circle)

if you got a 150 MB file as 2D export, it means you exported to somthing else than jpg (such as PDF or dwg, but I still find it huge) remember that if you export as PDF you won’t keep transparency properties

Hi, I have looked back at my view settings and I have it as hidden line. I’m hoping to export it as a black and white image hence I am looking to use as opposed to the monochrome setting. Is there a way to export it as a line drawing in monochrome?

I also do not mind if the image is transparent as such but the sketchup model itself seems to export the model as a transparent/wireframe object when its selected to be in hidden line. I can’t seem to find what is changing it between the sketchup screen and the exported pdf.

Thank you for your response!

This then might be a graphic card driver issue. have you tried updating your mx250 ? go to nvidia website and download latest drivers. then restart your computer and see if problem persists.

Also, when exporting to pdf, go to the option dialog and reset to default

Hi. I have just updated the graphics card driver from their website and restarted my computer. It doesn’t seem to have worked. I appreciate your help and if you have any other solutions that may work

Can you share the .skp file?

Since not everything in your first image shows as wireframe, it’s not that. I suspect it’s actually a graphics problem. It would be interesting to try the image export on another computer to compare the results

Out of curiosity, how far is your model from the origin?

For some reason it won’t let me upload the file directly but I have set up a we transfer if that’s ok:

My origin sits within one of the buildings!

Because it’s 360 Mb!

Actually it doesn’t. You’ve moved the model axes to where the building is but the building is more than a kilometer from the origin. The origin is a fixed point in space with the axes intersecting there when they are in their default location. Here I’ve reset the axes. Moving the axes does not move the origin.

Moving your model to the origin will surely help with the problem you are having.

I’ve fixed the incorrect tag usage…
Screenshot - 4_29_2021 , 2_31_36 PM

…and purged unused.
Screenshot - 4_29_2021 , 2_33_54 PM
this has reduced the file size by almost 80%.

I moved the entire model so the building is near the origin and this is what I see when I set up a view similar to the one you show.

It would be a good idea to go through your model and correct the reversed faces. All of the blue faces in the following screen shot are oriented incorrectly.

Looking at the components in your model, it looks like you could manage without a lot of them. Probably don’t need things like the Ryobi and DeWalt name components and many other details that would never been seen.

2 Likes

Oh brilliant thank you! I’m a little new to sketchup so I would never have got there!

Would it be possible for you to send me the improved model? I’d be very grateful

I haven’t deleted anything but unused components and did not change the incorrect face orientation. Do you need the map of all the streets in town? Here’s the link for the file without the map. The building didn’t fit into the map correctly anyway.

Currently 94% reduction in file size without map and hidden buildings.

FWIW, you might consider simplifying the 3D printers and the woodworking machines. Consider how small of a contribution they make to the overall model. They probably aren’t worth the file size contribution.

Brilliant thank you! I’ll start to purge some of the machinery within to simplify the model a little. Thank you again for your help!

1 Like