Hidden Geometry is visible and can't disable it

I was working on a model and I must’ve clicked some kind of shortcut by accident and all of my hidden geometry appeared and I can’t seem to hide it again. The “hidden geometry” option is off in the “view” tab, and I’ve tried toggling it off/on. How do I fix this?

k is the toggle for Back Edges on and off.

1 Like

Thank you so much!