Hidden Face - Cannot Unhide

I have this simple group that started life as four lines and a face. The face mysteriously became hidden and I cannot unhide it. I opened the group for edit and select the face, but no unhide option. I then tried the outliner, but again failed. Any ideas?

HiddenFace.skp (78.0 KB)

The face is hidden inside a group. Double left click to open the group, then single right click on the face and choose unhide. Works for me on Mac, Mojave SU20.

1 Like

Always fun when you hide something inside a group or component. Same for deleting guides you must be inside the group or component in which it resides to delete it.

1 Like

That’s not quite right. When you do Edit->Delete Guides (or use your keyboard shortcut) it deletes the guides in the current context and all guides inside any groups or components in the current context, even down to multiple levels of nested components.

1 Like

I’ll have to figure out what the conditions are that I run into this. I confirmed what you indicated. It is usually if fairly complex drawings that I run into the issue.

If component 1 contains 2 and 3, component 2 contains 4 and 5:

   /   \
  2     3
 / \
4   5

Whilst editing component 3, Delete Gudes will only delete guides in component 3. If you’re editing component 1, delete guides will delete guides in components 1, 2, 3, 4 and 5.

1 Like

That must be whare I was seeing it happen. Thanks!

Thanks to all. I thought I opened the group for editing, but must be wrong. And then I thought that edit>unhide all was recursive, again wrong. I mistakenly thought that delete guides and unhide all has similar behaviors. Learned something today, so not all is lost. :grinning: :mask:

endlessfix, thanks for coming to my rescue again.

1 Like