Help with - This does not appear to be a sketchup model

Hello, I have an frustrating problem and am getting the “This does not appear to be a SketchUp model” message.
Since the 20th April, I have been unable to open my model (Viewway 7.skp), nor earlier saved versions of the model (Viewway 6, etc.). Strangely there is the original model that still opens (Viewway.skp), which unfortunately was created months ago.
I can only think there is some common reference/content I inserted in the model, a long time ago, that it calls upon when opening these models 2, 3,… 7 etc that it can no longer reference.

Does anyone have any thoughts on how to solve this riddle?
I am happy to upload these models if it would help.

You might try sharing the .skp file here. @colin has some success with recovering at least components and materials in files that have become corrupted.

First you need to download the file to your computer. Button top left corner, Download. Then upload the file here. You should be able to drag it and drop it into a reply. If it’s too large to upload here, upload it to DropBox or Google Drive and share the link.

Viewway 7.skp (1.7 MB)

Thanks.
The only thing i can think of is maybe i added a location, which seems to make reference to an external map software system. I am thinking that it might have been at around this time that i was starting to think about solar access, and aligning it with the northern orientation.
But other than that, i’m lost…

Colin might be able to sort it out. Hopefully he’ll have time shortly.

I tried opening it in SU2022 and get an immediate Bug Splat.

Its just weird, the model and its predecessors were all working fine one evening, and then all of a sudden, they all stopped working, except the original. I just feel that its either the software that’s been changed and it doesn’t like content carried on in the set of files, or the files make reference to an external link now missing (hence the maps reference). It seems structural rather than an individual corruption in a file. The BugSplat is interesting.

I looked at the release notes for sketch/trimble and didn’t see anything unusual, or coinciding with the dates.

Anyway, much appreciated for any help. Regards.

I suspect it’s something that got added to the files. Hard to say what exactly.

I presume this is a hobby project or similar. You might want to start again and watch very closely what you are adding to the file.

Yes, hobby/renovation for a house. Yes, being very careful with the new model now. Thanks.

1 Like

I was able to open the file you uploaded. Here is what I see in SketchUp:

Is that what you expected?

I must point out that there are a number of problems with the model, though.

You are assigning tags to edges and faces. Tags should only be assigned to groups, components, and non-geometric objects such as dimensions and images.

You have several unused components and materials in the model that are taking up space without doing anything.

There are a lot of faces oriented with their back sides outward (visible as blue faces in your model). Back sides will be ignored by many renderers and may be masked if you paint a material onto them. Make a habit of working in monochrome while building a model and keep on top of face orientation by right-click reverse faces when they are inevitably created by some editing operations. Don’t apply materials to objects until the model is essentially finished.

I didn’t have time to review the structure of your model other than to note that you are using groups exclusively. Where there are repeated identical objects (e.g. pillars) you can make life a lot easier by using components instead of groups, since if you edit one instance of a component all the others will immediately change to reflect the edit.

It looks like something that is fixed in the desktop version hasn’t been applied to the web version. Opening and saving the file on desktop gives a file that does work in the web version.

You will still want to go through slbaumgartner’s suggestions, but here at least is a file that will work for you:

Viewway 7 resaved.skp (1.7 MB)

Thank you @slbaumgartner and @colin, much appreciate. It is working again.

Regarding the suggestions - i think many of the incorrect tags were assigned in my early days of learning to use the software. I’m not sure how to clean out bad stuff, so think i’ll just leave it as it is for the time being. If the model again starts to play up then might need to systematically clean up.

Thank you for explaining how to reverse the faces.

Will bear the component thing in mind. I had seen tutorials but had never found a particular need for it in my models, but can definitely see the relevance.

I’ve been thinking of upgrading to the desktop version as have found the tagging, while useful, still limiting.

Anyway, I really appreciate the help, and think its a great thing to be involved in this forum.

Hello all I am having the same issue and crunched for time. I thought I could finish to day. a 6 week project. I worked on the file last not and went back to it this morning and recieve the message "This does not appear to be a sketchup model. PLEASSSSSSSSSSSSSSSSE HELP ME

You need to let people with the link have access to the file.