Help with cutting wood planks

Practice 1.skp (211.1 KB)
hello friends,

I need little advice, how can I easily trim my floor wood planks as my floor size. I made my wood planks a component. If I make them unique and try to cut it the whole face deletes.

Can any one guide how can I do it?

All your floor planks are instances of the same component. If you want to trim the ends of some, you have to make those planks unique. And if you just draw a line across the top face, then use push/pull, you will only trim the top face, not the edges. You’ll need to create a cutting plane and intersect it with the plank, then erase the waste.

I made those planks unique drew a rectangle push pulled it but I think I didnot intersected it and tried to erase them. I will try again!!!

thanks for the quick help!!!

You could use Eneroth Solid Tools to trim the edge pieces after making those that get the same trimming unique. What is the value of modeling this as individual components? A texture would communicate the same thing, be easier to trim to shape, and create less of a hit on file size.

I created a texture from your tiles be exporting an image of the model, cropping it appropriately, and then importing it as a texture which I applied to a copy of your group.

Practice 1.skp (1.0 MB)

If you really need to work with cutting the planks I would suggest Making a single one unique first. Trim it as appropriate and then replace the other like ones with the trimmed one.
Here I did a few of them to show. The component thumbnail needs updating but I didn’t take the time to do that in the gif.

1 Like

I did it as exactly but still I am unable to cut wooden plank as per floor size. Earlier I thought I didn’t intersected so that was my mistake but I still unable to do it
Example 2

I don’t have Eneroth Solid Tool installed on my system could not find it in Sketchup Extension Warehouse. you are saying my plank image is not a texture, I downloaded it from web access it through Material tab I didn’t imported it. how can I create a texture of my plank image?

for my learning purpose I need to understand and do it. the gif you sent you used extension I don’t have that. so what is my next option?

@davidheim1 drawing line was not giving me to push/pull it dont know what I was doing wrong so I used rectangle tool

for 99,9% of the users, none, you’re right. if I couldn’t find the right photo, I would probably use an extension like Architexture and make the exact wood texture I need.
I’ve trained a guy from a tiling company once, making fancy floors with multiple tiles patterns and colours. In his case, he needed the tiles to be individual to get a count of each sort / colour in the end, plus a list of all the cuts he needed to make on site.

But I think that’s the only reason I see to make it plank or tile by tile. otherwise, slapping a good material is fine.
That was a fun training session :slight_smile:

@ateliernab I got that extension thanks :slight_smile:

train me as well, I need extensive training. I am doing it for my learning purpose :slight_smile:

thank you all !!!

by the way in my own I was working very good :confused:

The cutting plane has to be perpendicular to the plank. The plane is like a saw. Position the cutting plane where you want to cut the plank. Select the plane and go to edit>cut. Then open a plank component and go to Edit>paste in place. This puts the cutting plane within the plank component. Now, with the plank component open, select all the geometry; the easiest way is by drawing a box from left to right to take in the cutting plane and the plank. Next, go to Edit>intersect faces>with selection. Finally, erase everything you don’t want.

I was hoping to find a video somewhere that would show this, but I was unable to.

I installed Eneroth Solid Tool, tried it as your gif but its not working.
Example 3

You didn’t make a group or component for the cutter and you made a nested group of the plank you want to cut. It’ll work correctly if you group the geometry for the box you’ve drawn and quit making nested groups of the planks.

Eneroth Solid Tools requires that both the objecting getting trimmed and the object doing the trimming are both solid groups or components. Raw geometry and nest groups will never be solids.

@davidheim1 I tried to follow your instructions as well but it didn’t worked either. I tried both options Intersection Faces with Model, and with Selection no result. when I try to erase the side I want to it erases the whole plank.

Example 4

its not a nested group, I made a single plank made it a component and then copied it to my floor. they are not grouped.

Therein lies the problem.

In your video capture you show right clicking on the plank and selecting Make Group from the context menu. That is creating a nested group since the plank was already a component. And you never selected the geometry of the cutter box to make it a group.

Start a new file. Draw a plank and make it a component. Draw a cutter shape and make it a component or group. Then use Eneroth Solid Tools to cut the plank with the cutter.

If you do this correctly it will work like I showed. The fact that it isn’t working for you shows that you aren’t actually following the instructions.

The same applies in your reply to @davidheim1. You are not following his instructions. You left out

before getting the Eraser tool. You need to, of course, select the geometry of the cutting face and the plank before running Intersect Faces>With Selection so there is a selection to intersect.

Here. I made you a simple file so you can learn how to use Eneroth Solid Tools.
Miss Lazy.skp (20.0 KB)

This is what it should look like if you do it correctly.

1 Like

In my video capture I first made a rectangle, then push/pulled it through my plank then I made selected plank unique and then tool bar-> Eneroth Solid Tool-> subtract → plank → rectangle

you didn’t told me that both should be Component or groups not a raw geometry.

I really appreciate your patience. thanks a million I learned a bit of a extension today.