Help with bounding edges

advice

#1

Hi, I am experiencing some problems with the image that is imported from a vector file. i have created the faces, and it worked fine on the major part of the image, but there is one part that does not create shapes. I tried to redraw the lines by hand, the same result. When i choose “select binding edges”,only fe lines are selected. Attaching the screenshot. I spent a hole day today trying to resolve this problem. Any ideas?


#2

The=screenshot displays the bounding edges selected


#3

Add a few lines (red in image example) to delimit surfaces. They probably lost when the file was imported.


#4

Better upload the .skp file. Maybe the import is on a group and you have to edit it to draw the edges that are missing


#5

Hi, thanks! I have tried to do that, but the new lines also don’t appear as bounding


#6

Thanks, here is the file (sorry, is too large to upload to the forum): https://drive.google.com/open?id=1AWLoWW00s6jPwmEzs3wQbOOjYsQs-8Lj


#7

aprilburn, I use SketchUp Make 2017, I can not directly check your SKP 2018 file. To increase your chances of getting help from multiple members, try to save the SKP files you post as files for a more old version (ex: 2014).
I will first load your file into my 3Dwarehouse private account (your file will not be public there) so I can download a SKP 2017 version and only then I will try to see which lines are missing or not matching.


#8

Thank you! I have uploaded the 2017 version, hopefully it works: https://drive.google.com/open?id=1ubQFfk7zqhVD7x2mHfHLBbC4C5KOduKF


#9


aprilburn, you still have plenty of lines that overlap but do not close all to create delimited areas.

I drew some red, but all the missing lines need to be drawn. Or re-imported from the original file only those in that area.

As MikeWayzovski said, it’s possible that the original drawing may require small adjustments, and then importing it is no longer a problem.


#10

For starters: Layers in SketchUp do not separate geometry (Edges and Faces)
Groups and components do and you are not drawing in the right ‘context’ (Group/Component).
You can see it more clearly if you set the Face-Style to monochrome and uncheck layer1

The outliner displays the hierarchy of the model, for now it is best to explode (3x), turn layer1 off, select the drawn edges and delete (or EDIT>CUT) and then delete layer1 ( choose Move to current layer).
Select freehand tool and start drawing! Watch carefully that you select endpoint (green dots) If there is a closed loop, the edges will become thin and innerface can be erased.


#11

Another issue you have is that some edges are very tiny.
SketchUp’s built-in tolerance is 1/1000" [0.0254mm]
Any points closer than that are regarded as coincident and a new edge won’t form and any associated face is also lost.
Tiny geometry can exist but it cannot be created.
The trick is to use the ‘Dave-Method’ - search the forum for more detail.
This involves making a component of the object, making a copy and Scaling that instance up by x10 or x100, then you edit the big copy and the edges and faces are no longer tiny. When done you can return to the original small instance and all of the changes will be there too… delete the giant instance when you are done…

You also have several small stray edges which will prevent faces forming etc…


#12

Many thanks for your help and such detailed instruction! I will use this method!


#13

Thanks, yes that was the issue of tracing, I will search for the Dave - Method.


#14

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.