Importing SKP files

Hello Everyone.
I’m wondering if anybody can help! I’m using SketchUp Pro 2022 but experiencing problems trying to import a SKP. file without thousands of black spiderweb lines all over it. Please see attached two screenshots.
So SKP file 1 - I can open this file in a separate SketchUp window but when I try and import the same file into my drawing it adds thousands of black lines. I want to be able to load SKP file 1 into my drawing as the screenshot Image. A message box does appear - see attached.
The SKP files have been downloaded from Kaldewei website. SCONA | KALDEWEI
I would really appreciate any help anyone can give me as I’m new to SketchUp trying to learn.
Thank you in advance : )
Helen
P.S. I’m using Mac

SKP File issue.pdf (349.9 KB)

When you import the model, it comes with all the edges unsoftened and unsmoothed.

dsu-03

Those edges are in the same number whether you open the SKP file directly or import it.

Check Window > Model Info > Statistics > Show nested components to see the number of edges.

Basics of SketchUp about edges:

1 Like

When you open the freshly downloaded file from Kaldewei it does not show any edges (black spiderweb as you put it) because the folks who made the model saved it in a style that has the edges turned off. Try to draw a line with the pencil next to the tub, the line will disappear because the current style is set to not show edges. Go to View>Edge Style> Edges to turn on edge visibility and you sill see all the edges. This is a very lazy way of dealing with the edges on their part that makes the model look good on initial download but is not usable because it’s not practical to model in a style that has the edge visibility turned off. When you import to your own file the edges appear because you model has a current style that shows edges.

This is just an explanation of why you are seeing what you see. The fix is the same, as @mihai.s shows you should use soften/smooth to hide all the edges of that particular element so you don’t see the spiderweb even when using a style that shows edges for your modeling. Which is what the manufacturer should have done to their model in the first place before you downloaded it.

2 Likes

Also, be aware that all those edges add to the model size and workability while adding little to the model. I’m guessing it is a shower floor pan which could be modeled more efficiently and look just as good if not better.
So many models become bloated and unworkable because people add lots of these warehouse components that are not optimised for working in sketchup. Be very selective in what you add to your models.

1 Like

Hi Box, Riley & Mihai,

Thank you so mush for all your help & advice, I really appreciate it. I will give these recommendations a try!

Helen